Welcome to Linux Forums! With a comprehensive Linux Forum, information on various types of Linux software and many Linux Reviews articles, we have all the knowledge you need a click away, or accessible via our knowledgeable members.
Find the answer to your Linux question:
Site Navigation
Linux Forums
Linux Articles
Product Showcase
Linux Downloads
Linux Hosting
Free Magazines
Job Board
IRC Chat
RSS Feeds
Free Publications


The following steps (designed for Ubuntu OS menus) solved my HDMI Audio problem on my Ubuntu OS, but should do the job on every Linux OS using ALSA Sound driver. Furthermore, this a simple solution, using simple steps, suitable for new users (like myself) of the Linux distributions. I hope it will be helpful.


1. enter ubuntu software center
2. install GNOME ALSA Mixer
3. enter GNOME ALSA Mixer
4. mark the empty IEC958 checkbox as well
5. reboot
6. enter System / Prefernces / Sound
7. choose Hardware tab
8. choose profile: Digital Stereo (HDMI) Output


 
Rate This Article: poor excellent
 
Comments about this article
I still have the problem
writen by: djcrash1981 on 2011-01-10 14:06:50
Hi, thanks for your suggestion but i still have the problem and I haven't figure it out, how to solve it, here is some information about my system:


aplay -l
**** Lista de PLAYBACK dispositivos hardware ****
tarjeta 0: SB [HDA ATI SB], dispositivo 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 0: SB [HDA ATI SB], dispositivo 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: HDMI [HDA ATI HDMI], dispositivo 3: HDMI 0 [HDMI 0]
Subdispositivos: 0/1
Subdispositivo #0: subdevice #0


aplay -L
default
pulse
Playback/recording through the PulseAudio sound server
front:CARD=SB,DEV=0
HDA ATI SB, ALC662 rev1 Analog
Front speakers
surround40:CARD=SB,DEV=0
HDA ATI SB, ALC662 rev1 Analog
4.0 Surround output to Front and Rear speakers
surround41:CARD=SB,DEV=0
HDA ATI SB, ALC662 rev1 Analog
4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SB,DEV=0
HDA ATI SB, ALC662 rev1 Analog
5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SB,DEV=0
HDA ATI SB, ALC662 rev1 Analog
5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=SB,DEV=0
HDA ATI SB, ALC662 rev1 Analog
7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=SB,DEV=0
HDA ATI SB, ALC662 rev1 Digital
IEC958 (S/PDIF) Digital Audio Output
dmix:CARD=SB,DEV=0
HDA ATI SB, ALC662 rev1 Analog
Direct sample mixing device
dmix:CARD=SB,DEV=1
HDA ATI SB, ALC662 rev1 Digital
Direct sample mixing device
dsnoop:CARD=SB,DEV=0
HDA ATI SB, ALC662 rev1 Analog
Direct sample snooping device
dsnoop:CARD=SB,DEV=1
HDA ATI SB, ALC662 rev1 Digital
Direct sample snooping device
hw:CARD=SB,DEV=0
HDA ATI SB, ALC662 rev1 Analog
Direct hardware device without any conversions
hw:CARD=SB,DEV=1
HDA ATI SB, ALC662 rev1 Digital
Direct hardware device without any conversions
plughw:CARD=SB,DEV=0
HDA ATI SB, ALC662 rev1 Analog
Hardware device with all software conversions
plughw:CARD=SB,DEV=1
HDA ATI SB, ALC662 rev1 Digital
Hardware device with all software conversions
hdmi:CARD=HDMI,DEV=0
HDA ATI HDMI, HDMI 0
HDMI Audio Output
dmix:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 0
Direct sample mixing device
dsnoop:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 0
Direct sample snooping device
hw:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 0
Direct hardware device without any conversions
plughw:CARD=HDMI,DEV=3
HDA ATI HDMI, HDMI 0
Hardware device with all software conversions

Even I have put a report in the alsa project, trying to find out what is happening, I hope you can help me!!

Regards.
RE: I still have the problem written by djcrash1981:

Comment title: * please do not put your response text here