Find the answer to your Linux question:
Results 1 to 10 of 10
A while ago when I used Windows I used a program called MIDI-OX, which unfortunately doesn't exist for Linux. Does anyone know of a program for Linux that I can ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    9

    Cool MIDI - load and save MIDI sysex messages


    A while ago when I used Windows I used a program called MIDI-OX, which unfortunately doesn't exist for Linux. Does anyone know of a program for Linux that I can use for the same purpose?

    The features I am looking for are the following:
    Read MIDI dump from my external equipment. Those dumps are just sysex messages.
    Save those MIDI dumps as a file.
    Load those MIDI dumps from file.
    Send the MIDI dump back to the external device from which it came.

    It would also be nice to see when there is activity on the MIDI ports etc.

    Of course, the more features the better... Maybe there exist a feature that I just don't know yet that I need...

    And NO, NO, NO, I will NOT install Wine! I still have a Windows XP partition (even though I never use it) and if I really want to run a Windows-only program and I can't find a good replacement, I will just run it in Windows.



    Johnny Rosenberg

  2. #2
    Just Joined!
    Join Date
    Feb 2008
    Posts
    4
    SimpleSysexxer is what you're looking for :
    Simple Sysexxer

  3. #3
    Just Joined!
    Join Date
    Aug 2007
    Posts
    9

    Smile

    Quote Originally Posted by rdoursenaud View Post
    SimpleSysexxer is what you're looking for :
    Simple Sysexxer
    Thanks! I will have a look at it soon!

  4. #4
    Just Joined!
    Join Date
    Feb 2008
    Posts
    4
    Quote Originally Posted by guraknugen View Post
    [...]
    It would also be nice to see when there is activity on the MIDI ports etc.
    [...]
    Johnny Rosenberg
    Forgot to say that you also have gmidimonitor for this http://gmidimonitor.bountysource.com

    Have fun

  5. #5
    Just Joined!
    Join Date
    Aug 2007
    Posts
    9
    Thanks again! I will!

  6. #6
    Just Joined!
    Join Date
    Mar 2008
    Posts
    3
    Greetings, rdoursenaud. Regarding your recommendation of Simple Sysexxer, it looks like it will work except that on my system, I can't seem to load any .syx files that I've saved to my hard drive (with simplesysexxer). It just freezes up and I have no idea why. I don't get any error messages at all -- just a blank screen. Any ideas?

  7. #7
    Just Joined!
    Join Date
    Feb 2008
    Posts
    4
    I also hit this bug. The author is aware of the problem but don't have time atm to look at the issue that seem GUI related with newer QT3 versions than the recommended.
    I may look at the issue myself but I don't have time either...
    I'v had mixed result with its ancestor :SysExxer: Sysex tool for Linux

    Good luck!

  8. #8
    Just Joined!
    Join Date
    Mar 2008
    Posts
    3
    Hello rdoursenaud,

    Hmmmm...that seems strange since the website specifies: "You need both Qt4 binary and Qt4 devel packages installed...ensure you are using qmake from your Qt4 installation, qmake from Qt3 will not do the job." I used QT4 version libqt4-devel-4.3.3-5mdv2008.0 in my build. I also tried the RPM package from Suse10 and it behaved the same way.

    Yes, I've tried Sysexxer but it didn't work either. I also tried to install the csv version but I get a syntax error on configure:
    ./configure: line 24420: syntax error near unexpected token `ALSA,alsa'
    ./configure: line 24420: ` PKG_CHECK_MODULES(ALSA,alsa >= 1.0.0,with_alsa=yes,with_alsa=no)'

    I'm beginning to wonder if the issues I'm having are related to how my system is set up. I've tried to send sysex messages to my D50 using many different apps in both Linux and Windows. I can get sysex from the D50 but can't seem to send. Perhaps the D50 doesn't like receiving sysex through my M-Audio Axiom midi controller...

    Thanks for your help and suggestions. I'll keep trying.

  9. #9
    Just Joined!
    Join Date
    Feb 2008
    Posts
    4
    A little message to let you know that I managed to get Simple Sysexxer to open files.
    You can find my patch at http://rdoursenaud.free.fr/linux/ssr-openfile.patch.

    Hope it'll be useful to you.

  10. #10
    Just Joined!
    Join Date
    Mar 2008
    Posts
    3
    cool...thanks. I'll give that a go

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •