Find the answer to your Linux question:
Results 1 to 3 of 3
Im trying to get cdemu to work I get this error Makefile:31 *** You'll need sources for your (at least 2.6.16) kernel. Stop. I dont know what to do with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2007
    Posts
    32

    cdemu problem


    Im trying to get cdemu to work I get this error

    Makefile:31 *** You'll need sources for your (at least 2.6.16) kernel. Stop.

    I dont know what to do with this error can someone please tell me how to fix this so I can install cdemu thanks.

    Im using FC6.

  2. #2
    Just Joined!
    Join Date
    May 2007
    Posts
    32
    ok I installed the headers for the kernel I did yum install kernel-devel but now it gives me this error

    ke[1]: Entering directory `/usr/src/kernels/2.6.22.2-42.fc6-i686'
    CC [M] /home/a/cdemu-0.8/cdemu_mod.o
    /home/a/cdemu-0.8/cdemu_mod.c: In function ‘cdemu_exit’:
    /home/a/cdemu-0.8/cdemu_mod.c:198: error: too many arguments to function ‘invalidate_bdev’
    make[2]: *** [/home/a/cdemu-0.8/cdemu_mod.o] Error 1
    make[1]: *** [_module_/home/a/cdemu-0.8] Error 2
    make[1]: Leaving directory `/usr/src/kernels/2.6.22.2-42.fc6-i686'
    make: *** [default] Error 2

  3. #3
    Just Joined!
    Join Date
    May 2007
    Posts
    32
    Ive been searching in google and there is nothing I can find to help me install cdemu can anyone suggest any other program I can use thats like cdemu. I just want to use .cue and iso images.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •