Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all I get this error when attempting to ./configure Guifications for Pidgin: Code: checking pkg-config is at least version 0.7... yes checking for GLIB - version >= 2.0.0... *** ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2007
    Posts
    1

    Guifications ./configure error message and Glib version


    Hi all

    I get this error when attempting to ./configure Guifications for Pidgin:

    Code:
    checking pkg-config is at least version 0.7... yes
    checking for GLIB - version >= 2.0.0... 
    *** 'pkg-config --modversion glib-2.0' returned 2.14.0, but GLIB (2.12.11)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    no
    configure: error:
    *** GLib 2.0 is required to build Guifications; please make sure you have the
    *** GLib development headers installed. The latest version of GLib is always
    *** available at http://www.gtk.org/.
    I have installed the latest version of glib (2.14.0) but still the error message appears...

    I don't know where to look anymore, u guys have some place to point me to?

    Thanks in advance,
    Nathan.

  2. #2
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    What Linux distribution (and its version) are you using. Try uninstalling the version of glib2 you installed and then install the devel package for glib2 using your distributions package manager.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •