Find the answer to your Linux question:
Results 1 to 4 of 4
alright i installed the VM for linux "j2re-1_4_2_03-linux-i586.bin" it was installed correctly and everything, but when i go to install the "LimeWireLinux.bin" i get this error: Preparing to install... tail: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    Canada
    Posts
    45

    Help with installing LimeWire


    alright i installed the VM for linux "j2re-1_4_2_03-linux-i586.bin" it was installed correctly and everything, but when i go to install the "LimeWireLinux.bin" i get this error:

    Preparing to install...
    tail: `-1' option is obsolete; use `-n 1'
    Try `tail --help' for more information.
    ./LimeWireLinux.bin: line 326: [: `)' expected, found -z
    WARNING! The amount of /tmp disk space required and/or available
    could not be determined. The installation will be attempted anyway.
    Extracting the installation resources from the installer archive...
    Configuring the installer for this system's environment...
    No Java virtual machine could be found from your PATH
    environment variable. You must install a VM prior to
    running this program.

    any help would b nice, how do i add VM to my path environment variable? what is a path environment variable? please detailed instructions cause im a noob.....

  2. #2
    Just Joined!
    Join Date
    Jun 2004
    Posts
    33
    What distro are you using?

  3. #3
    Linux User Muser's Avatar
    Join Date
    May 2004
    Location
    Maryland
    Posts
    363
    have u considered other clients? gtk-gnutella?

    others:
    http://www.gnutella.com/connect/unix/

  4. #4
    Linux User
    Join Date
    Jan 2004
    Posts
    357
    Open up a terminal and type env and hit enter. In the output is your environemt settings for your user. In the output you will see path=/andabunchofstuff. This is where your the OS will look for programs when you try and run something (or when something is being installed in your case).

    Do some google searchs on setting path in linux to find out more.

    But if you want java avalible do something like this -

    Create a file called java.sh in /etc/profile.d/

    This file should contain the following lines. You have to modify the first line appropriately, according to what's actually in /usr/java/:

    export JAVA_HOME="/usr/java/j2re1.4.2_02"
    export JAVA_PATH="$JAVA_HOME"
    export PATH="$PATH:$JAVA_HOME/bin"

    To finish it up, do:

    chmod +x /etc/profile.d/java.sh

    Java should now work properly. You will need to log in and log out for some things to function properly.

    To install the browser (mozilla) plugin for java, as root, do:

    ln -sf /usr/java/<YourJavaDirectory>/plugin/i386/ns610-gcc32/libjavaplugin_oji.so /usr/lib/mozilla/plugins

    Replace <YourJavaDirectory> with the name of the actual directory.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •