Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, I am facing a problem in launching mozilla browser from a program which is running in a service.I have a java program which opens a port and launches ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2007
    Posts
    2

    problem launching mozilla from a service


    Hi all,
    I am facing a problem in launching mozilla browser from a program which is running in a service.I have a java program which opens a port and launches the mozilla browser from the terminal or CUI mode. When I run this program through a shell script everything works fine and the browser is easily started but when I tried to run the same program from a service, it opened the port but did not launch the browser.That means the service was running fine but still it could not launch the browser due to some unknown reason. Just to check the things I executed the runmozilla.sh from the service it gave an error as "GTK WARNING : Cannot open display" but the same command ran successfully to launch the browser when I tried it from the terminal.I am working on a Redhat Linux 8.0 and an RHEL 4, I need to create a service or something similar so that the task can be accomplished automatically at boot time or after the GUI is loaded, I am stuck with this therefore pls suggest some solutions.

    Thanks

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi maxone !

    Welcome to the LinuxForums. Duplicate Threads/Posts are not allowed here. Its against Forum Rules. Please continue here only.
    Thread Locked.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •