Find the answer to your Linux question:
Results 1 to 6 of 6
In Firefox 2.0.0.9, when I mouse over a link or when the page loads, text will sometimes slightly jump left, right, up or down maybe 2 millimeters. It seems almost ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    101

    Firefox fonts slightly move with certain actions


    In Firefox 2.0.0.9, when I mouse over a link or when the page loads, text will sometimes slightly jump left, right, up or down maybe 2 millimeters. It seems almost completely random but happens quite frequently and is very annoying. I have a lot of font packages installed. This jumping also happens on the text in the Firefox tabs.

    Also, I believe a related issue is if I have say an XTerm over Firefox and I close the XTerm, the area where the XTerm was will slightly jump back in to position, about a 1/2 second after the XTerm is closed.

    I've been having this problem on multiple distributions: Debian, Slackware, and Archlinux.

    Thanks!
    --Erik

  2. #2
    Just Joined!
    Join Date
    Nov 2007
    Posts
    3
    I have been having this very same error since I updatded to 2.0.0.9. Links of all kinds, within Divs, within ordinary anchors, inside of paragraphs, and nested in just about everything else, along with the tabs and their close buttons, seem to jump when the mouse hovers over them (in completely arbitrary directions but consistently 1-2 pixels)... but if I minimize and remaximize the window, it fixes all of them until I mouse over again. I use the new Fedora core 8 distro, use Compiz Fusion (Though I highly doubt that's the issue if you don't use it), and imported my settings from my old machine that had Fedora core 7 and Firefox 2.0.0.8.

    Would be nice if someone could help with this one. I'm trying to resolve this on my own, but so far no luck. It does not seem to happen for my friend who uses the same linux distro, the same firefox, and the same compiz (with the same settings nonetheless on most of this!!), and neither of us have figured it out yet.

  3. #3
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    101
    That sounds completely identical... I switched to FreeBSD recently which is still 2.0.0.8 in its ports and the problem disappeared. I was on a different distro and on Fluxbox, so the issue probably lies in 2.0.0.9.

    I thought after the fact maybe there is an addon that is doing it... maybe try:

    Code:
    firefox --safe-mode
    and see what happens.
    --Erik

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2007
    Posts
    3
    Hang on a second... this is weird...

    Before even trying anything else (including safe mode... I only use 2 addons though, cooliris and fireftp), I opened it this morning and it worked fine. Even the website that every link was jumping... But I think I figured that out, it's my website, I made a change to it that was a little corrupt and fixed it :P

    I'll see if the problem comes up again, and if it does I may be able to fix it... I would hate to ever have to drop fedora in favor of another distro or to disable compiz though, I just figured all the new stuff out lol... Even the see-thru cube with extra faces and a 3d screensaver in the center and image behind it, plus the fade, blur, zoom, rectangle screenshot and annotation+water and rain effects... lol

    I've also attempted to duplicate the issue on a windows box I use for testing a ton of stuff I built in fedora and it seems that only the Linux distros of 2.0.0.9 do it. Hope they permanently fix it soon...

  6. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    I've been using Firefox 2.0.0.9 since the day it was released and have not seen this issue at all, so maybe it's not with Firefox. Maybe changing to a different font would fix it.
    oz

  7. #6
    Just Joined!
    Join Date
    Nov 2007
    Posts
    3
    well... I did get it to stop (almost completely)...
    I just rebooted a couple times and now only the tabs and occasionally some image links do it. But it does seem that it is just the distros of FF for each distro of Linux... Either way, I'm kinda fine now that it is not nearly as frequent, and I'm sure it'll get patched in 2.0.1.0... Besides, I'm having too much fun with Compiz Fusion and the plgu-ins to notice this small detail at times :P

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •