Find the answer to your Linux question:
Results 1 to 10 of 10
I'm trying to save a new document in OpenOffice.org to a USB flash disk in Word97+ .Doc format. When I click [Save] it just comes up with an error saying ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2007
    Posts
    29

    OpenOffice.org won't save new file


    I'm trying to save a new document in OpenOffice.org to a USB flash disk in Word97+ .Doc format. When I click [Save] it just comes up with an error saying that the file doesn't exist, when it's a new document just created. The USB disk is definitely detected, but the LED it's got built in doesn't seem to light up, if that's of any significance.
    Attached Images Attached Images

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Try removing space or replace it with under_score in Filename.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    I tried saving to usb, saving to files works on my system if I select directory by going to documents and navigate back to root and select media etc eg /media/usbdisk/
    this also allows spaces in file names.

    If I try to select media direct eg media:/sda1/ I get an error message
    Saving using protocol "media" is not supported.

    Can you save the file in your document area and then copy it across to the USB media? eg can you write to the media?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2008
    Posts
    8
    The same thing happesn to me. When I click on Save or SaveAs, OpenOffice Crashes Here is the message I get:

    OpenOffice.org - Document Recovery

    Due to an unexpected error OpenOffice.org crashed. Akl the files you were working on will now be saved. The next time OpenOffice.org is launched your files will be recovered automatically. The following files will be recovered.

    Untitled1, Untitled2 Untitled...

    When I launch OpenOffice after that, the files go through a recovery process and are opened as they were when I tried to save.

    Also get a similar problem in gedit. When I save, it crashes but I lose the data content.

    Any suggestions anyone?

    David

  6. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Do you have enough free space in your HD?
    Post the output of this
    Code:
    df -h
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #6
    Just Joined!
    Join Date
    Sep 2008
    Posts
    8

    Plenty of free space

    Yes, I have a 500GB drive with 13GB in use 487GB free, Plenty of disk space.

    David

  8. #7
    Just Joined!
    Join Date
    Sep 2008
    Posts
    8
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda1 457G 4.9G 429G 2% /
    varrun 363M 112K 363M 1% /var/run
    varlock 363M 0 363M 0% /var/lock
    udev 363M 60K 363M 1% /dev
    devshm 363M 28K 363M 1% /dev/shm
    lrm 363M 39M 324M 11% /lib/modules/2.6.24-19-generic/volatile
    gvfs-fuse-daemon
    457G 4.9G 429G 2% /home/david/.gvfs
    df: `/media/GALLUPSOLAR': Input/output error
    /dev/sdd1 1009M 204M 805M 21% /media/GALLUPSOLAR_
    david@desktop1:~$

  9. #8
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,915
    This could be tied to the share/lock issue for some kinds of filesystems, try turning off file locking. Do this by finding the 'soffice' script ('which soffice' or 'locate soffice' should turn it up).

    Edit the file and look for the lines that say:
    Code:
    # file locking now enabled by default
    SAL_ENABLE_FILE_LOCKING=1
    export SAL_ENABLE_FILE_LOCKING
    comment it out like this:
    Code:
    # file locking now enabled by default
    #SAL_ENABLE_FILE_LOCKING=1
    #export SAL_ENABLE_FILE_LOCKING
    and save the file out again. You'll probably have to edit the file as root.
    Linux user #126863 - see http://linuxcounter.net/

  10. #9
    Just Joined!
    Join Date
    Sep 2008
    Posts
    8
    Roxoff,

    Thanks. I'll try it tomorrow and let you know if it works. Sounds like possible solution.

    David

  11. #10
    Just Joined!
    Join Date
    Sep 2008
    Posts
    8

    content of my soffice.sh

    # configuration file to set up some environment variables for OOo

    # File locking; possible values are:
    # - yes: enable file locking unconditionally
    # - no: disable file locking
    # - auto: enable file locking, when the document is found on a nfs share
    # If the environment variable SAL_ENABLE_FILE_LOCKING is set,
    # the setting if ENABLE_FILE_LOCKING has no effect.

    FILE_LOCKING=auto

    # OpenGL support; may cause trouble with the restricted nvidia and fglrx
    # drivers; possible values are:
    # - yes: enable OpenGL support unconditionally
    # - no: disable OpenGL support.
    # - auto: only enable OpenGL support, if not running with the restricted
    # nvidia and fglrx drivers.
    # If the environment variable SAL_NOOPENGL is set,
    # the setting if OPENGL_SUPPORT has no effect.

    OPENGL_SUPPORT=no


    This file found in etc/openoffice/soffice.sh there is another soffice in: usr/bin
    Should I comment out 'FILE_LOCKING=auto' ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •