Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
I have been hearing that Mplayer is the best media player for Linux, but I haven't a clue where to get it. I am running Fedora Core 1 with a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    JFM
    JFM is offline
    Just Joined!
    Join Date
    Jun 2004
    Posts
    21

    Mplayer?


    I have been hearing that Mplayer is the best media player for Linux, but I haven't a clue where to get it. I am running Fedora Core 1 with a 2.4 Kernel. Anyone know where to get the rpm from?THANX.

    Peace,
    John

  2. #2
    Linux Newbie
    Join Date
    Jul 2004
    Location
    www.syracuse.com
    Posts
    119
    i don't know about the rpm. but i do know how to do it from source. and its easy too. plus it will be optimized to your computer.

    just go to http://www.mplayerhq.hu/homepage/design7/dload.html and download MPlayer v1.0pre5 and Blue-1.4.tar.bz2. then type in.

    $tar -xvjf MPlayer-1.0pre5.tar.bz2
    $cd MPlayer-1.0pre5
    $./configure --enable-gui
    $make
    $su
    #make install
    #exit
    $tar -xvjf Blue-1.4.tar.bz2 ~/.mplayer/Skin/
    $mplayer

    and you should see mplayer pop up and ready to go. at least this is what i did on my computer.

  3. #3
    JFM
    JFM is offline
    Just Joined!
    Join Date
    Jun 2004
    Posts
    21
    Alright. does that give me the gui as well or do I have to install that afterwards? If so where do I get the gui? THANX for the help.

    Peace,
    John

  4. #4
    Linux Newbie
    Join Date
    Jul 2004
    Location
    www.syracuse.com
    Posts
    119
    the --enable-gui option when you ./configure gives you the gui. if you forget to add this you just get the command line version. also, mplayer doesn't have a skin by default. that's why i told you to get the blue file. if that doesn't exist it mplayer won't run either.

  5. #5
    JFM
    JFM is offline
    Just Joined!
    Join Date
    Jun 2004
    Posts
    21
    U can tell how much of a n00b i am..thanx for the help

  6. #6
    Linux Newbie
    Join Date
    Jul 2004
    Location
    www.syracuse.com
    Posts
    119
    no prob. i was once one too. and in some respects still am.

  7. #7
    JFM
    JFM is offline
    Just Joined!
    Join Date
    Jun 2004
    Posts
    21
    I did what u told me to, but when I tell it to run i get this error:
    Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
    Reading config file /root/.mplayer/config
    [cfg] read config file: /root/.mplayer/gui.conf
    Reading config file /root/.mplayer/gui.conf: No such file or directory
    vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)
    Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No such file or directory
    Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
    Using built-in default codecs.conf.
    font: can't open file: /root/.mplayer/font/font.desc
    font: can't open file: /usr/local/share/mplayer/font/font.desc
    Using Linux hardware RTC timing (1024Hz).
    Can't open input config file /root/.mplayer/input.conf: No such file or directory
    Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
    Falling back on default (hardcoded) input config
    SKIN dir 1: '/root/.mplayer/Skin'
    SKIN dir 2: '/usr/local/share/mplayer/Skin'
    [skin] file ( /usr/local/share/mplayer/Skin/default/skin ) not found.
    Skin not found (default).

    any help?

    Peace,
    John

  8. #8
    Linux Newbie
    Join Date
    Jul 2004
    Location
    www.syracuse.com
    Posts
    119
    why are you running it as root?

  9. #9
    JFM
    JFM is offline
    Just Joined!
    Join Date
    Jun 2004
    Posts
    21
    Because when i told it to unzip the skin, it told me that i didnt have permission to do so. so, ii logged in as root to unzip it. i have aim if u think that talking to me might help: jfmanamtr.

  10. #10
    Linux Newbie
    Join Date
    Jul 2004
    Location
    www.syracuse.com
    Posts
    119
    if you did the
    $./configure --enable-gui
    $make
    #make install

    then just make sure that the skin is placed in your home directory, and not in root. then it should work.

    for future reference do as little as possible as root. for instance, if you can't modify a file that you want to be able to just use
    #chmod 777 filename
    and then you can do whatever you want to it as a normal user. also you should never log in as root. you should always log in as a normal user and just su to root, and once the task is done just exit.

    hope it works.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •