Find the answer to your Linux question:
Results 1 to 8 of 8
Earlier today, I opened a DiVX video file in xine (which has worked excellently so far) and it played the video but not the audio. The actual problem was that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    Urbana, IL
    Posts
    4

    xine malfunction


    Earlier today, I opened a DiVX video file in xine (which has worked excellently so far) and it played the video but not the audio. The actual problem was that I had XMMS paused instead of stopped, so the sound card was blocked (consider sound-mixing a peripheral problem to be fixed later). Before I realized that this was the problem, though, the only thing I changed was to ./install the DiVX 5.0.5 package again. (I had previously installed it in an attempt to get MPlayer working, which ended up not working.)

    After unblocking the sound channel, I watched a DiVX movie in xine without problems. The next time I went to watch something, though, it played the audio and had a plain blue video output. Several other files, including the movie that worked earlier and non-DiVX videos, had the same result. My first effort to troubleshoot was removing xine through Synaptic, and then reinstalling it, to no avail.

    What should be my next tactic? Thanks in advance for the help!

  2. #2
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Oklahoma City, OK
    Posts
    232
    Delete the contents of ~/.xine(should have been your first step). It shoule have catalog.cache, config & keymap. Afterwards, restart Xine and reset your settings.
    OH NOOOOO!!!!!! You did it the way I said?

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Location
    Urbana, IL
    Posts
    4
    That did not fix the problem. The video output is still the same blue screen.

  4. #4
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Oklahoma City, OK
    Posts
    232
    Hmm. What video output codec is it using?
    OH NOOOOO!!!!!! You did it the way I said?

  5. #5
    Just Joined!
    Join Date
    Jul 2004
    Location
    Urbana, IL
    Posts
    4
    Where would I find that? (I'm pretty n00b at this.)

  6. #6
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Oklahoma City, OK
    Posts
    232
    Open Xine. Start the configuration editor. In the GUI section, "Configuration Experience Level" needs to be set to "Master of the Known Universe". If it is set to beginner, change it and click apply. Go to the "Video" tab. Make sure "deinterlace method" is set to "onefield" and "video driver to use" is set to "auto". Click "Apply".
    Next, go to the "Codec" tab. Make sure the "path to Win32 codecs" is correct.
    OH NOOOOO!!!!!! You did it the way I said?

  7. #7
    Just Joined!
    Join Date
    Jul 2004
    Location
    Urbana, IL
    Posts
    4
    All of those settings were right, and didn't need me to change them. The screen is still blue.

  8. #8
    Linux User zba78's Avatar
    Join Date
    Feb 2004
    Location
    Birmingham, England
    Posts
    335
    Which UI are you using? Xine-ui, GXine Kafiene? What version of xine-lib are you running. The latest one is xine-lib-1rc5 i believe
    Ubuntu Jaunty :: Arch Linux (current) :: Acer Aspire 1692WMLi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •