Dear all,

I read the mplayer's manual, it said we can use the option "-display <name>" to control the mplayer video output to the specify location using Xserver's hostname and display number.

Now I have a project need to control the mplayer through remote console, like putty, SecureSSH, and using the "-display" option to control the mplayer to display the video on X. It's failed. Mplayer didn't show on the X and the sound come out. The movie is playing with no video output.

So, can anyone give me some suggestion on this issue? I already found those topic on google but still have no solution?

command is

Code:
mplayer -display localhost:0.0 /tmp/test.avi

Now, I do a test and found a very interesting problem.
I change it to console mode. /etc/inittab set id=3 and run startx, then I run the same command, it's work, the mplayer can run on X with sound and video, work fine.
Then I change the /etc/inittab id=5, then I run the same command, the result is the same, mplayer is running without video output, just have sound.

WHY!?!?! and I check the command
startx command
Code:
root      1714  1698  0 12:08 tty1     00:00:00 xinit /etc/X11/xinit/xinitrc -- -auth /root/.serverauth.1698
root      1715  1714  6 12:08 tty3     00:00:02 X :0 -auth /root/.serverauth.1698
and /etc/inittab id = 5
Code:
root      1326  1323  0 12:12 tty7     00:00:01 /usr/bin/Xorg :0 -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt7
I thinks the problem is here!?!? start with different options.
But I don't know how to correct, the let display localhost:0.0 can use when /etc/inittab id=5 not startx.


Regards,
Bluesheet