Find the answer to your Linux question:
Results 1 to 1 of 1
Hi all, I just started using mutt. I just went through some articles and set my .fetchmailrc as Code: poll pop.gmail.com with proto POP3 and options no dns user "svzard@gmail.com" ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2007
    Location
    Bangalore, India
    Posts
    27

    unable to send/reply to mails in mutt


    Hi all,
    I just started using mutt. I just went through some articles and set my .fetchmailrc as

    Code:
    poll pop.gmail.com with proto POP3 and options no dns
    user "svzard@gmail.com" is "svzard" here options ssl
    and set my ~/.muttrc as

    Code:
    # My email address
    set pop_user="svzard@gmail.com"
    # To ensure mutt doesnot put 'username@localhost.localdomain in From:
    set from="svzard@gmail.com"
    set use_from="yes"
    set envelope_from="yes"
    # The test editor I want to use to write emails (the default is nano)
    set editor=vi
    As you can see, its pretty simple stuff. Just copied what I could make out from other's .muttrc file on the net and put my ids.

    I'm able to read mails by running
    Code:
    $ fetchmail -vk
    $ mutt
    in that order.

    But I'm not able to send or reply to mails using mutt. Only webmails can be downloaded.

    What is missing here. I read the manual but could not grasp anything useful. Can you help me with the settings?

    Btw, mutt -v on my system gives:
    Code:
    Mutt 1.4.2.2i (2006-07-14)
    Copyright (C) 1996-2002 Michael R. Elkins and others.
    Mutt comes with ABSOLUTELY NO WARRANTY; for details type `mutt -vv'.
    Mutt is free software, and you are welcome to redistribute it
    under certain conditions; type `mutt -vv' for details.
    
    System: Linux 2.6.18-8.el5 (i686) [using ncurses 5.5]
    Compile options:
    -DOMAIN
    -DEBUG
    -HOMESPOOL  -USE_SETGID  -USE_DOTLOCK  -DL_STANDALONE  
    +USE_FCNTL  -USE_FLOCK
    +USE_POP  +USE_IMAP  +USE_GSS  +USE_SSL  +USE_SASL  
    +HAVE_REGCOMP  -USE_GNU_REGEX  
    +HAVE_COLOR  +HAVE_START_COLOR  +HAVE_TYPEAHEAD  +HAVE_BKGDSET  
    +HAVE_CURS_SET  +HAVE_META  +HAVE_RESIZETERM  
    +HAVE_PGP  -BUFFY_SIZE -EXACT_ADDRESS  -SUN_ATTACHMENT  
    +ENABLE_NLS  -LOCALES_HACK  +HAVE_WC_FUNCS  +HAVE_LANGINFO_CODESET  +HAVE_LANGINFO_YESEXPR  
    +HAVE_ICONV  -ICONV_NONTRANS  +HAVE_GETSID  +HAVE_GETADDRINFO  
    -ISPELL
    SENDMAIL="/usr/sbin/sendmail"
    MAILPATH="/var/mail"
    PKGDATADIR="/usr/share/mutt"
    SYSCONFDIR="/etc"
    EXECSHELL="/bin/sh"
    -MIXMASTER
    To contact the developers, please mail to <mutt-dev@mutt.org>.
    To report a bug, please use the flea(1) utility.
    Well, I even added set sendmail="/usr/sbin/sendmail -oem -oi" to .muttrc. No help still.
    Last edited by svzard; 12-13-2007 at 06:02 PM. Reason: tried setting sendmail option too

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •