Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
When trying to install the RPMs for Kopete and WINE, they both return the message "permission denied" even when I run them as root. How do I install RPMs? >_< ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Ed
    Ed is offline
    Just Joined!
    Join Date
    Jan 2003
    Location
    Texas
    Posts
    59

    I hate RPMs.


    When trying to install the RPMs for Kopete and WINE, they both return the message "permission denied" even when I run them as root. How do I install RPMs? >_<

    My OS is Red Hat 8.0 Pro.

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    try typing su -
    and then your root password for full root permissions if the regular su doesn't work

    I though red hat 8 came with wine already.


    rpms are awesome! They are usually the easiest to install.

  3. #3
    Just Joined!
    Join Date
    Mar 2003
    Location
    KY -- USA
    Posts
    21
    yowwww, he said that he was running them as root... I think the problem is the permissions.

    Find the RPM, right-click, go to permissions and make sure that it is executable. For some reason, atleast on my machine (was RH 8 now running RH 9) most of the RPMs I got were not executable.

    I had this same problem which is why I remember this.

    Hope this helps.
    Even more... I hope I'm right... lol.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    Guy79 - in case you didn't already know, there is a difference between typing "su" and "su -".
    One gives you root permissions for installing and the latter gives you FULL root permissions. That could be the problem.

    If not, then it could be what you said, but he said that they were rpm files. The kind of issue you are talking about is usually associated with rpm.bin files. He said it was an rpm file, not an rpm.bin file unless he left that part off, which is huge cause then the answer to his question would be totally different. I can only answer a question as effectively as it is asked, after all.

    Either way, there is a command list for files on my guide that instructs how to install every different kind of linux file (as far as I know).

  6. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    yow:
    I think you've missed the point with su -. What do you mean that "root privileges for installing" would be?
    The - in su - is an abbreviation for -l, which means that su does a full login. Just su just changes to root and forks a shell. root is, however, nontheless root. Unless you're using POSIX capabilities (which su doesn't), there's no way of being "less" root.
    The login option changes only two aspects of su's behavior:
    1. It runs bash as -bash.
    2. It clears the entire environment and sets TERM, HOME, SHELL, USER, LOGNAME and PATH. It also includes /sbin and friends in PATH.

    Guy79:
    RPMS aren't supposed to be executable (it's not like you run them, right?).

    Ed:
    Could you give the entire error message?

  7. #6
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    well, like a lot of things in linux from time to time, sometimes, doing something like changing a small parameter can make all the difference. I have seen what I mentioned work when the regular SU did not. Maybe it was a glitch in the way the program was written that was trying to be installed, maybe it was something else. Nonetheless, I have seen it be the difference between something working and not working.
    Sometimes, it takes something unconventional to get something to work. Not all of us play by ALL the rules ALL the time.

  8. #7
    Just Joined!
    Join Date
    Mar 2003
    Location
    KY -- USA
    Posts
    21
    Dolda, that is exactly what I thought too, but that fixed it when I changed the permissions.

    But I have a habit of doing things the extemely hard way to without knowing it. lol.

  9. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    yow:
    Do you think it might just have been some badly written post-installation script that assumed that you were root and tried to run stuff in the sbin directories without using the full path?

    Guy79:
    Are you sure that the RPM just wasn't set as non-readable?

  10. #9
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    it could have been a variety of things, it didn't actually happen to me, but it did work for the other person

    open source is great, but you have to rely on often new and untested software sometimes

  11. #10
    Ed
    Ed is offline
    Just Joined!
    Join Date
    Jan 2003
    Location
    Texas
    Posts
    59
    This is trying to run Kopete's RPM without changing permissions:

    [root@Linux Files]# ./kopete-0.6.1a-4rh80akc.i386.rpm
    bash: ./kopete-0.6.1a-4rh80akc.i386.rpm: Permission denied

    This is trying to run WINE's RPM without changing permissions:

    [root@Linux Files]# ./wine-20030219-1rh8winehq.i686.rpm
    bash: ./wine-20030219-1rh8winehq.i386.rpm: Permission denied

    This is trying to run Kopete's RPM after changing permissions:

    [root@Linux Files]# ./kopete-0.6.1a-4rh80akc.i386.rpm
    bash: ./kopete-0.6.1a-4rh80akc.i386.rpm: cannot execute binary file

    This is trying to run WINE's RPM after changing permissions:

    [root@Linux Files]# ./wine-20030219-1rh8winehq.i686.rpm
    bash: ./wine-20030219-1rh8winehq.i386.rpm: cannot execute binary file

    I'm clueless...there's no installation instructions, etc. as this came as a sole RPM, not in a tarball. I actually tried changing the file permissions before. Any ideas?

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •