Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I am a new member in this forum. I have an issue in hand, hope i can find a solution. I am using a SunOS and i use at ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2007
    Posts
    2

    Question 'at now' command not working


    Hi,

    I am a new member in this forum. I have an issue in hand, hope i can find a solution.

    I am using a SunOS and i use at command to run scripts. However recently I found out that the 'at now' utility is not working.

    When i run the job i see the id being assigned to it, however the script doesn't start.

    (sdcapc01p:ops)$ at now
    at> Test.sh
    at> <EOT>
    commands will be executed using /bin/ksh
    job 1198101608.a at Wed Dec 19 17:00:08 200

    when i use at -l to display all the jobs scheduled using at now i see the job id.

    (sdcapc01p:ops)$ at -l
    1198101608.a Wed Dec 19 17:00:08 2007

    I have tested the script using other methods(like nohup, and ./Test.sh) and the scripts seems to run fine.

    Could anyone please help me out to fix this issue as i run most of the jobs using at now.

    Thanks in advance

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    Not sure but I believe you need to give the Path to the file in the 'at' command.
    Have you tried this?

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Just Joined!
    Join Date
    Dec 2007
    Posts
    2
    I tried to run the scripts by giving full path names as well as using the ./scriptname , but the issue still persists

  4. #4
    scm
    scm is offline
    Linux Engineer
    Join Date
    Feb 2005
    Posts
    1,044
    Is it an environment issue? ISTR that at (and cron) runs with a pretty basic, minimal environment, so if you're assuming something will be set for you, assume again.

    You could try running the job through cron in case that gives you more clues about what's happening (cron emails stdout/stderr to the job owner).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •