Find the answer to your Linux question:
Results 1 to 7 of 7
I've worked my way through a number of dependency problems in installing GTK+-2.4.0, but this one has me so stumped that I have to post. When I try to configure ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246

    Why and how GTK+-2.0's dependencies make me cry


    I've worked my way through a number of dependency problems in installing GTK+-2.4.0, but this one has me so stumped that I have to post.

    When I try to configure GTK, the following happens:
    Code:
    dan@george:~/gtk+-2.4.0$ ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... no
    checking for mawk... mawk
    checking whether make sets $(MAKE)... yes
    checking for native Win32... no
    checking for gcc... gcc
    ...
    checking tiffio.h usability... yes
    checking tiffio.h presence... yes
    checking for tiffio.h... yes
    checking for jpeg_destroy_decompress in -ljpeg... no
    configure: WARNING: *** JPEG loader will not be built (JPEG library not found) ***
    configure: error:
    *** Checks for JPEG loader failed. You can build without it by passing
    *** --without-libjpeg to configure but some programs using GTK+ may
    *** not work properly
    Now I definitely have libjpeg installed, and just to be sure I installed version 6.2 from source. It went with no problems.
    Code:
    dan@george:~/$ locate libjpeg.so.62
    /usr/lib/libjpeg.so.62
    /usr/lib/libjpeg.so.62.0.0
    I've tried many different solutions I found on Google, including changing my LD_LIBRARY_PATH variable to include /usr/lib, but I always get the same error. I also checked the options of configure, but there is nothing like "--libjpeg-path=[PATH]", unfortunately. Can you think of any reason why the GTK+-2.4.0 configure script might not see my JPEG library?
    Situations arise because of the weather,
    And no kinds of love are better than others.

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Location
    MN USA
    Posts
    70
    Maybe its looking for a symbolic link to libjpeg? You should be able to open the gtk installation file, normally the var's used are all defined right at the top, look for something with libjpeg OR jpeg_destroy_decompress and see where it points, an env var. or a sym. link.

    Hope that helps

  3. #3
    Linux User
    Join Date
    Jul 2004
    Posts
    256
    Do you have an old version of libjpeg that doesn't have "jpeg_destroy_decompress"?

    I've tried many different solutions I found on Google, including changing my LD_LIBRARY_PATH variable to include /usr/lib, but I always get the same error. I also checked the options of configure, but there is nothing like "--libjpeg-path=[PATH]", unfortunately. Can you think of any reason why the GTK+-2.4.0 configure script might not see my JPEG library?
    Does your /etc/ld.so.conf have that path ? Mine doesn't, but does have /usr/local/lib

    After you edit that file, I think you have to run ldconfig.
    --monkey

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    I tried looking in the code of ./configure, but it's way over my head. I'm not that good at bash scripting.

    I tried adding a symlink to /usr/lib/libjpeg.so.62.0.0 in /etc/X11/lib as libjpeg.so.62, but still no good.

    My /etc/ld.so.conf file contained only the path "/usr/X11/lib", so I added "/usr/lib" and ran ldconfig. Still the same error.

    I'm pretty sure 6.2 is the most recent version of libjpeg, so if it didn't have jpeg_destroy_decompress I would be very surprised and offended.

    Any more thoughts?

    EDIT: I posted GTK's configure script here, and my output here in case that helps at all.

  6. #5
    Linux User
    Join Date
    Jul 2004
    Posts
    256
    Just a tip, to make errors easier to find, when configuring/making you can do this
    Code:
    $ ./configure 2>errors
    $ less errors
    $ make 2>errors
    $ less errors
    It redirects stderr to a file named "errors"

    I did a google and this forum came up with a tut :P http://www.linuxforums.org/tutorials...g-HOWTO-7.html

    this might help: http://www.tldp.org/HOWTO/Program-Li...libraries.html

    Did you edit the file as root? Did you run ldconfig as root? Did it keep your entry or remove it after you ran ldconfig?

    What's the output of:
    Code:
    # ldconfig -v | grep jpeg
    I checked, I have version 62 also.
    --monkey

  7. #6
    Linux Newbie
    Join Date
    May 2004
    Location
    Boston, MA
    Posts
    246
    I'll read those links voraciously in a bit, but in the meantime:

    I edited /etc/ld.so.conf as root and ran ldconfig as root. /etc/ld.so.conf still contains the path I added to it.

    The output of ldconfig -v | grep jpeg is:
    Code:
    ldconfig: Path `/usr/lib' given more than once
       libjpeg.so.62 -> libjpeg.so.62.0.0
    And here are the contents of my /etc/ld.so.conf file:
    Code:
    /usr/X11R6/lib
    /usr/lib
    Now for some light reading...

    EDIT: I just tried all of
    Code:
    ./configure --with-libjpeg=/usr/lib
    ./configure --with-libjpeg=/usr/lib/libjpeg.so.62
    ./configure --with-libjpeg=/usr/lib/libjpeg.so.62.0.0
    but still nothing.

  8. #7
    Just Joined!
    Join Date
    Jun 2007
    Posts
    1

    Smile How to fix your problem

    Execute this command:

    sudo ln -s /usr/lib/libjpeg.so.62.0.0 /usr/lib/libjpeg.so
    so that gtk can find your libjpeg (I think this might be a bug in the configure script, don't know and right this minute don't care) but it will get you past the problem

    Next one you might run into is that when building libjpeg, you need to install the headers too

    jpeg-6b$ sudo make install-headers

    then ./configure for gtk will be happy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •