Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I have an issue that blocks my apt-get, aptitude and Ubuntu software/security appl work properly. I tried to install cinelerra, then I had to install a new line on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3

    apt-get removal scripts


    Hello,

    I have an issue that blocks my apt-get, aptitude and Ubuntu software/security appl work properly.

    I tried to install cinelerra, then I had to install a new line on /etc/apt/sources.list
    that is
    deb Akirad Repository akirad-gutsy main

    However , I am not sure the proper reason, but it has a incompatibility to other applications I have. Then I decided to REMOVE the cinelerra. But, when I tried to remove or when I make ANY operation on apt-get I have the following screen
    gustavo@gustavo-laptop:~$ sudo apt-get install -f
    [sudo] password for gustavo:
    Lendo lista de pacotes... Pronto
    Construindo árvore de dependências
    Reading state information... Pronto

    Os pacotes a seguir serão REMOVIDOS: REMOVED
    cinelerra-k8
    0 pacotes atualizados, 0 pacotes novos instalados, 1 a serem removidos e 2 não atualizados.
    1 pacotes não totalmente instalados ou removidos.
    É preciso fazer o download de 0B de arquivos.
    Depois de desempacotar, 23,7MB de espaço em disco serão liberados.
    Quer continuar [S/n]? s
    (Lendo banco de dados ... 133303 arquivos e diretórios atualmente instalados.)

    Removendo cinelerra-k8 ... Removing cinelerra
    Removing any system startup links for /etc/init.d/cinestart ...
    rm impossible to remove
    `/etc/init.d/cinestart': File or folder not found
    dpkg: error processing cinelerra-k8 (--remove):
    subprocesso post-removal script returns error exit code 1
    Errors were found while trying to remove the application
    cinelerra-k8
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    it blocks any application installation!!!!

    So I tried apt-get update and apt-get install -f several times, but I always had the same message

    In my opinion there are 2 possible ways:
    - fix the installation problem
    - remove it, manually, from apt-get concerns

    The first option should be the best but not the easiest, and as usual, I want the easiest.

    so, HOW can I REMOVE an application of apt-get list of dependences, or how can I change the cinerella script and make it easier to be removed?

    I do not worry about remove completely cinerella from my comnputer, I just want to have APT working again!!!!


    Thanks

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you removed akirad-gutsy main source from sources.list file?
    Execute this
    Code:
    sudo apt-get clean all
    sudo apt-get update
    sudo apt-get remove cinelerra
    Post error message here, if any.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3
    Replying your message:
    Have you removed akirad-gutsy main source from sources.list file?
    yes

    sudo apt-get clean all
    ok

    sudo apt-get update
    ok

    sudo apt-get remove cinelerra
    actually, cinelerra does not exist, cinelerra-k8 is the one ... but assuming that .... I had the same error
    Removendo cinelerra-k8 ...
    Removing any system startup links for /etc/init.d/cinestart ...
    rm: imposível remover `/etc/init.d/cinestart': File or Folder not found
    dpkg: error processing cinelerra-k8 (--remove):

    Errors were found while processing: (translated, it should be a different message, but similar)
    cinelerra-k8
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Folks, by this error, I would like to change the script which remove cinerella-k8 from my computer: modify the script and tell the system that every change was successfully done. Is that a good way to do (yeah, I know that some file/folder can reside on my computer, however I do not have any issue with that)


    Thanks for your attention

  4. #4
    Just Joined!
    Join Date
    Jan 2008
    Posts
    3

    Smile

    Great! I found the solution!
    As it was requiring files to be deleted, I have created all of them with touch ( touch /etc/init.d/cinestart ) and I found too the file that has the installation script that was
    /var/lib/dpkg/info/cinelerra-k8.postrm
    I changed "some"
    if
    fi
    that it was doing some strange actions. Thus I commented
    # if
    # ....
    # fi

    and it has worked fine!!!!

    Now I can work with apt-get again!!!




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •