Find the answer to your Linux question:
Results 1 to 5 of 5
I installed all the necessary ports and have a nice cube rotating in Gnome, but there are problems. After doing: Code: compiz --replace --indirect-rendering decoration png svg wobbly fade minimize ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630

    Almost got Compiz going but need help


    I installed all the necessary ports and have a nice cube rotating in Gnome, but there are problems. After doing:
    Code:
    compiz --replace --indirect-rendering decoration png svg wobbly fade minimize cube rotate zoom scale move resize place switcher &
    The window frames disappear, icons won't open apps and I can't get a right click menu. Essentially, a desktop crash but the mouse and cube still work fine. I'm using an Nvidia 7300 (512 mb) with the very latest 3d drivers. Keep in mind, that I just got Gnome up and running fairly satisfactorily in Crux but have been having little issues here and there which may or may not be related. Any help appreciated.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,759
    I've used Compiz Fusion on several ATI and Nvidia video cards. When using an Nvidia with the latest driver, here are the options I set after installing the driver:

    Code:
    nvidia-xconfig --composite
    nvidia-xconfig --render-accel
    nvidia-xconfig --add-argb-glx-visuals -d 24
    With the latest Nvidia driver, I'm not enabling AIGLX, but I'm also not turning on Xgl.

    After restarting X, I check that the correct driver is loaded:

    Code:
    glxinfo | grep rend
    (Ensure it's Nvidia and not Mesa.)

    And also check that composite is enabled:

    Code:
    cat /var/log/Xorg.0.log | grep -i comp
    If all is OK, I start compiz-manager to enable Compiz. I add compiz-manager to my Gnome sessions options for auto startup.

    HTH.

  3. #3
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Thanks HROAdmin26. I did everything you said with the desired results, but no change. I still get an active cube but with a locked down desktop. I appreciate your help.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,759
    Hmmm....are you enabling Xgl (or maybe it's been enabled)? I get the same issues if I enable it...

    I don't know what's installed on your distro, but you can try

    Code:
    gnome-xgl-switch --disable-xgl
    And then reboot/restart X.

  6. #5
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I was going from this page and am configured to use AIGLX. Mainly because it said dbus wasn't needed as it is with XGL, and I've been getting dbus errors when trying to run Beryl. I have both installed I get the same result out of either. I can go back to XGL if you think I'd have better luck...

    Hmmm. I get a "command not found" when running that command you gave. A "locate" doesn't turn it up either...
    Linux Mint + IceWM Registered: #371367 New Members: click here

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •