Find the answer to your Linux question:
Results 1 to 8 of 8
Hi every1 I really need help from you because this is the first time i am working on a Linux system and i have no idea how to install applications ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2008
    Posts
    3

    Install icecast & GCC not working (NEWBIE)


    Hi every1

    I really need help from you because this is the first time i am working on a Linux system and i have no idea how to install applications

    alright so yesterday i have baught a Linus VPS (Virtual Private Server) from a company in order to use it as a Internet Radio streaming server.

    Ok so i have downloaded Icecast server from the icecast.org website
    the file is named icecast-2.3.1.tar.gz

    so i have uploaded the file using SSH to the foler home/icecast that i have created.

    So i have used the Tar command to untar the file and it worked

    After that i have tried the command ./configure

    when i did that i got the following

    [root@vps1246 icecast]# ./configure
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for gcc... no
    checking for cc... no
    checking for cc... no
    checking for cl... no
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details.
    [root@vps1246 icecast]#



    So clearly i can see the following error

    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details
    .


    Ok after googling this error msg i found out that i have to install GCC because i need a compiler.

    So i went on gcc.gnu.org and i had the choice to download several files

    I have chosen the one called gcc-4.3.0.tar.bz2 which is 60MB

    so i have uploaded this file using SSH to a new folder i have created called GCC

    in that folder i have used the following command to Untar the file

    tar xvjf gcc-4.3.0.tar.bz2

    the file was untared

    at this point i have tried the ./configure command and go the same error mesg as before

    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details
    .


    so here's where i need your help, how do i install the GCC now ?
    can some1 give me a detailed explenation ?

    thanks

  2. #2
    Linux Newbie
    Join Date
    Mar 2008
    Location
    Hyderabad
    Posts
    109

  3. #3
    Just Joined!
    Join Date
    Mar 2008
    Posts
    3
    Quote Originally Posted by digvijay.gahlot View Post

    nope not really

  4. #4
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    First we need to know what distribution you are using. You should really start reading docs, because we can't teach you to use linux, we can only help, but not do the work for you.

    If you can't even find how to install packages using your package manager, I highly doubt that you are prepared to compile anything by hand on your own.

    So, try to find out what distro you are using and let us know. Look the documentation provided by the manufacturer or your box, or ask them directly what OS did they install into it.

  5. #5
    Just Joined!
    Join Date
    Mar 2008
    Posts
    3
    it's Linux - CentOS

  6. #6
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Then you should be using rpm, which is the package manager for CentOS (Mandrake, RedHat and Fedora, as well).

    I don't use CentOS (never used it), but it shouldn't be any different than any other distro using rpm.

    Use rpm -i to install a given package, and -q to query for packages. I'd start reading the man page for rpm. I can't give any more concrete help with CentOS, but surely someone around can. I would start installing icecast directly. You shouldn't need gcc if icecast is available in binary form in the centos repositories.

  7. #7
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    Odds are the compiler is already installed on the system, you just need to add it to your path. Ask them if it is installed, and where it is installed. Than add it to your path. You can search how to add something to your path in much less time than I can tell you here.

    CentOS has a package management system, go to a CentOS wiki or documentation and read up on how to search and install packages.
    Operating System: GNU Emacs

  8. #8
    Just Joined!
    Join Date
    Mar 2009
    Posts
    1
    i am getting the same problem as was described in the 1st post....
    i am on fedora 9... can anyone help me plzz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •