Find the answer to your Linux question:
Results 1 to 2 of 2
I am trying to backup some local files (NTFS) using ssh. When I run Code: rsync -av --delete-after --modify-window=1 --exclude-from=/home/me/Scripts/rsyncexclude ssh me@mydomain.com /media/Shared/ /home/me/backup/Shared/ > /home/me/Scripts/rsync-${TIMESTAMP}.log 2>&1 I get Code: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2008
    Posts
    1

    Rsync errors


    I am trying to backup some local files (NTFS) using ssh. When I run

    Code:
    rsync -av --delete-after --modify-window=1 --exclude-from=/home/me/Scripts/rsyncexclude ssh me@mydomain.com /media/Shared/ /home/me/backup/Shared/ > /home/me/Scripts/rsync-${TIMESTAMP}.log 2>&1
    I get

    Code:
    rsync: link_stat "/home/me/ssh" failed: No such file or directory (2)
    rsync: link_stat "/home/me/me@mydomain.com" failed: No such file or directory (2)
    rsync: mkdir "/home/me/backup/Shared" failed: No such file or directory (2)
    rsync error: error in file IO (code 11) at main.c(529) [receiver=2.6.9]
    rsync: connection unexpectedly closed (8 bytes received so far) [sender]
    rsync error: error in rsync protocol data stream (code 12) at io.c(454) [sender=2.6.9]
    I can ssh to the remote server using the same username and manually mkdir so I am confused. Any suggestions?

  2. #2
    Just Joined!
    Join Date
    Apr 2008
    Location
    Southern California
    Posts
    6
    Have you tried switching the / to \ since windows uses \ and linux uses /?

    Im assuming your going from windows to linux so have it setup this way.


    rsync -av --delete-after --modify-window=1 --exclude-from=\home\me\Scripts\rsyncexclude ssh me@mydomain.com \media\Shared\ /home/me/backup/Shared/ > /home/me/Scripts/rsync-${TIMESTAMP}.log 2>&1

    Not sure if it will work, but worth a try.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •