Find the answer to your Linux question:
Results 1 to 6 of 6
yesterday i installed mplayer on fedora 2 using the command "yum setup mplayer" - it downloaded a bunch of dependecies & finally istalled. then i was able to open mplayer, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Location
    Israel
    Posts
    61

    MPlayer opens & instantly closes on Fedora2-KDE


    yesterday i installed mplayer on fedora 2 using the command "yum setup mplayer" - it downloaded a bunch of dependecies & finally istalled. then i was able to open mplayer, i even tried to view a movie with it & it worked perfectly.

    today i try to open mplayer it pops up (i see it for 1/2sec) and instatly closes, there is no warning message or anything like that

    what could be the problem ?
    // i would include my mplayer version but i do not know how to recevie that info

    thank you for any help.

    [edit] : just a thought : maybe it is better to just tell yum to reinstall the player ? if so, how do i do that ?

  2. #2
    Just Joined!
    Join Date
    May 2004
    Location
    Israel
    Posts
    61
    well, i did "yum remove mplayer"
    then did again "yum install mplayer"
    that worked ok, but i still get the same result when i try to open mplayer.

    once thing i did noticed is that it only closes when i try to load the mplayer-gui, when i tried to view the movie using the commmand line version of mplayer it worked ok and i was able to view the movie.

    any idea's., anyone ?

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Can you try running mplayer-gui from the command line? Then when it crashes, it should give you some info about what caused it.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    try running the following from a command shell:
    mplayer options --vo x11
    Mplayer used to do the same thing for me, but when I tried that, it never crashed again!
    Good Luck
    -lakerdonald

  5. #5
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    to start the mplayer GUI from the command line the command is

    Code:
     gmplayer

  6. #6
    Just Joined!
    Join Date
    May 2004
    Location
    Israel
    Posts
    61
    yes that is correct, to start mplayer GUI you use the command
    Code:
    gplayer
    anyway i tried to run it from the console, it told me it can't find any defualt skin to display
    i went(//how do you spell that-> go in past?) to http://www.mplayerhq.hu/homepage/design7/dload.html downloaded Blue-1.4.tar.bz2 to /usr/share/mplayer/Skin
    Code:
    chmod a+x Blue-1.4.tar.bz2
    & now it works perfectly, thank you.

    // ps : i kinda like the command version more now (:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •