Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I just installed VSFTPD 2.0.1 under RH 8 2.4.x kernel and can't connect via cuteftp; when I run the command /usr/local/sbin/vsftpd & via putty ssh to test the install, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Posts
    2

    VSFTPD Install or Connect or config problem


    Hi,

    I just installed VSFTPD 2.0.1 under RH 8 2.4.x kernel and can't connect via cuteftp; when I run the command
    /usr/local/sbin/vsftpd &
    via putty ssh to test the install, I get the error:

    Code:
    500 OOPS: vsftpd: not configured for standalone, must be started from inetd
    However when I ran the above command before, it tested out OK. But I was never able to get cuteftp pro to connect via ssh2 so I started tinkering around with my vsftpd config files, nothing seems to work.

    How would I start from inetd? Also I configured vsftpd to run under xinetd per the install instructions I got from http://vsftpd.beasts.org/. Could this be a conflict somewhere in my config files? Or do I also need to config it to run under ssh? I am able to get an SCP connection via WINSCP.

    Also, when I run
    kill -HUP `pidof xinetd`
    , I'm getting a

    # 500 OOPS: could not bind listening IPv4 socket
    error after trying to start via the
    Code:
    # /usr/local/sbin/vsftpd &
    [1]
    command.

    Thanks anyone for any suggestions.

  2. #2
    Just Joined!
    Join Date
    Jul 2004
    Posts
    10

    vsftpd

    listen=yes
    should be in your /etc/vsftpd.conf in order to make it run as stand-alone.
    You did not mention having done this, so I thought I should point it out.

    Something like
    listen_port=21
    Should be working by default, but this is the way you can change it.

    I personally find something like:
    killall -HUP xinetd
    easier, though I admit killing by pid is mucho more macho

    Concerning the binding problem, I guess something else is taking that port. nmap localhost might help.
    As for running it "under ssh", I'm not sure what you mean. sshd takes care of my ssh traffic for me. (Usually it's at port 22), config file located at /etc/ssh/sshd_config

    Good luck, and have fun!

  3. #3
    Just Joined!
    Join Date
    Aug 2004
    Posts
    2
    Hi Stilus,

    Thanks much, yes I ldid have isten=yes in /etc/vsftpd.conf, that did not work so I took it out and it did not allow a connect either. I'll try it again though.

    Does "killall -HUP xinetd" do a xinetd (and vsftpd) restart? Or does it reload the config files? Or both?


    Actually when I killed by pid I did not use the process number, I used the exact command as I posted above, took it out of my Linux book. Should I have found the process ID of xinetd first, THEN insterted the process id number into pid above? Maybe I never even killed xinetd and that's why it's not running?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •