Just got a box setup with a new Nvidia card with a DMS-59 style output so I decided to setup two monitors. Everything seems to be working great minus the fact xlock will no longer run since I've enabled xinerama.

xlock:
Code:
calvin[75] [~/]> xlock
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  78 (X_CreateColormap)
  Serial number of failed request:  89
  Current serial number in output stream:  95
My xorg.conf
Code:
calvin[76] [~/]> cat /etc/X11/xorg.conf

Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" RightOf "Screen0"
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
        Option "Xinerama" "true"
EndSection

Section "Files"
        RgbPath      "/usr/X11/lib/X11/rgb"
        ModulePath   "/usr/X11/lib/modules"
        FontPath     "/usr/X11/lib/X11/fonts/TrueType/"
        FontPath     "/usr/X11/lib/X11/fonts/Type1/"
        FontPath     "/usr/X11/lib/X11/fonts/Type1/sun/"
        FontPath     "/usr/X11/lib/X11/fonts/F3bitmaps/"
        FontPath     "/usr/X11/lib/X11/fonts/misc/"
	FontPath     "/usr/X11/lib/X11/fonts/100dpi/"
	FontPath     "/usr/X11/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
	Load  "IA"
	Load  "dbe"
	Load  "extmod"
	Load  "record"
	Load  "xtrap"
	Load  "glx"
	Load  "bitstream"
	Load  "type1"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "keyboard"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/mouse"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	#DisplaySize	  360   290	# mm
	Identifier   "Monitor0"
	VendorName   "SUN"
	ModelName    "4"
	HorizSync    30.0 - 121.0
	Option	    "DPMS"
EndSection

Section "Monitor"
	#DisplaySize	  360   290	# mm
	Identifier   "Monitor1"
	VendorName   "SUN"
	ModelName    "4"
	HorizSync    30.0 - 121.0
	Option	    "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "UseFBDev"           	# [<bool>]
        #Option     "Rotate"             	# [<str>]
        #Option     "VideoKey"           	# <i>
        #Option     "FlatPanel"          	# [<bool>]
        #Option     "FPDither"           	# [<bool>]
        #Option     "CrtcNumber"         	# <i>
        #Option     "FPScale"            	# [<bool>]
        #Option     "FPTweak"            	# <i>
	Option     "ConnectedMonitor" "DSP-0"
	Identifier  "Card0"
	Driver      "nvidia"
	VendorName  "nVidia Corporation"
	BoardName   "NV44 [Quadro NVS 285]"
	BusID       "PCI:1:0:0"
	Screen	0
EndSection

Section "Device"
	Identifier  "Card1"
	Option     "ConnectedMonitor" "DSP-1"   # <str>
        Option "HorizSync" "31.0-80.0"
        Option "VertRefresh" "56.0-76.0"
	Driver      "nvidia"
	VendorName  "nVidia Corporation"
	BoardName   "NV44 [Quadro NVS 285]"
	BusID       "PCI:1:0:0"
	Screen 1
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth 24
	SubSection "Display"
		Viewport   0 0
		Depth     1
		Modes    "1280x1024"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
		Modes    "1280x1024"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
		Modes    "1280x1024"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
		Modes    "1280x1024"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280x1024"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x1024"
	EndSubSection
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Card1"
	Monitor    "Monitor1"
	DefaultDepth 24
	SubSection "Display"
		Viewport   0 0
		Depth     1
		Modes    "1280x1024"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
		Modes    "1280x1024"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
		Modes    "1280x1024"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
		Modes    "1280x1024"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "1280x1024"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x1024"
	EndSubSection
EndSection
Any help would be greatly appreciated.