Find the answer to your Linux question:
Results 1 to 4 of 4
Hello all. I have set up FTP pure on my Linux Ubuntu 6.06.1 LTS server and I can connect as a virtual user via FileZilla - great! However the bit ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2008
    Posts
    7

    Pure FTPd- I want some virtual users to have access to entire server


    Hello all.

    I have set up FTP pure on my Linux Ubuntu 6.06.1 LTS server and I can connect as a virtual user via FileZilla - great!

    However the bit I am now stuck on, and have been so for a while is allowing the FTP user connected the ability to access all directories on the server and to be able to PUT and GET files.

    I have set the conf/ChrootEveryone=YES and NO (!) and restarted but to no avail...

    I am sure the is a more secure way than allowing the user to break out of their root...

    Any ideas, what I am really trying to achieve is for the ability for the Web Admin person to be able to connect via FileZilla and put updates live for the web site.

    Hope one of you clever people out there can help either fix my problem, or advise some other options...

    If it helps, I used these 2 links as a reference guide to get where I am so far:

    Pureftpd Server Configuration in Debian
    PureFTPd Installation and Setup - Debian Wiki

    Be nice, I am new to all this (Linux that us)

  2. #2
    Just Joined! javilin93's Avatar
    Join Date
    Jun 2008
    Location
    Atlanta
    Posts
    36
    Hello
    Have you tried changing the direcories permission so that your user's group can read and write??
    If you don't know how just right click the directory and click properties then go to the permissions tab

    hopefully this helped

    oh and you can also use konqueror too just
    Code:
    ftp://username:password@domain.com
    Last edited by javilin93; 06-27-2008 at 06:20 AM. Reason: needed to add some stuff

  3. #3
    Just Joined!
    Join Date
    Jun 2008
    Posts
    7
    Thanks

    Running on a server with no GUI.

    I have moved on to set a mount bind to the FTP user connecting to the area they need access to, and then given the FTP user rights to the directory their home directory is now redirected to.

    Found this link useful in getting me here (that and a few hours head scratching!?)

    Allowing FTP access to files outside the home directory chroot | MDLog:/sysadmin

    It maybe there are better solutions, but this seems to work now

  4. #4
    Just Joined! javilin93's Avatar
    Join Date
    Jun 2008
    Location
    Atlanta
    Posts
    36
    You could try using chmod to change the permissions
    here is a link
    How to use chmod

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •