Find the answer to your Linux question:
Results 1 to 2 of 2
I'm trying to read a rtsp stream over network and view/record it. PlayBin works fine with rtsp like below; $ gst-launch playbin uri=rtsp://localhost:5554/Camera1 It displays the stream. But I couldn't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    1

    Question Gstreamer - Creating a pipeline that will read from RTSP


    I'm trying to read a rtsp stream over network and view/record it. PlayBin works fine with rtsp like below;

    $ gst-launch playbin uri=rtsp://localhost:5554/Camera1

    It displays the stream. But I couldn't get it work with my own pipeline;

    $ gst-launch -v rtspsrc location=rtsp://localhost:5554/Camera1 ! decodebin ! fmpegcolorspace ! textoverlay text="fsvbzlvcjzjhkvhlkczvjkd " ! autovideosink

    This gives an error like this;

    `--> gst-launch -v rtspsrc location=rtsp://localhost:5554/Camera1 ! decodebin ! ffmpegcolorspace ! textoverlay text="fsvbzlvcjzjhkvhlkczvjkd " ! autovideosink
    Setting pipeline to PAUSED ...
    /pipeline0/rtspsrc0/rtpdec0: latency = 3000
    /pipeline0/rtspsrc0/udpsrc0: timeout = 5000000
    /pipeline0/rtspsrc0/udpsrc5: timeout = 5000000
    Pipeline is live and does not need PREROLL ...
    Setting pipeline to PLAYING ...
    New clock: GstSystemClock
    /pipeline0/rtspsrc0/udpsrc0: timeout = 0
    /pipeline0/rtspsrc0/udpsrc5: timeout = 0
    /pipeline0/decodebin0/typefind.src: caps = application/x-rtp, media=(string)audio, payload=(int)14, clock-rate=(int)90000, encoding-name=(string)MPA, npt-start=(guint64)0, npt-stop=(guint64)2783000000000, play-speed=(double)1, play-scale=(double)1
    /pipeline0/decodebin0/typefind.sink: caps = application/x-rtp, media=(string)audio, payload=(int)14, clock-rate=(int)90000, encoding-name=(string)MPA, npt-start=(guint64)0, npt-stop=(guint64)2783000000000, play-speed=(double)1, play-scale=(double)1
    /pipeline0/decodebin0.sink: caps = application/x-rtp, media=(string)audio, payload=(int)14, clock-rate=(int)90000, encoding-name=(string)MPA, npt-start=(guint64)0, npt-stop=(guint64)2783000000000, play-speed=(double)1, play-scale=(double)1
    /pipeline0/rtspsrc0.recv_rtp_src_0_662345911_14: caps = application/x-rtp, media=(string)audio, payload=(int)14, clock-rate=(int)90000, encoding-name=(string)MPA, npt-start=(guint64)0, npt-stop=(guint64)2783000000000, play-speed=(double)1, play-scale=(double)1
    /pipeline0/rtspsrc0.recv_rtp_src_0_662345911_14.proxypad2: caps = application/x-rtp, media=(string)audio, payload=(int)14, clock-rate=(int)90000, encoding-name=(string)MPA, npt-start=(guint64)0, npt-stop=(guint64)2783000000000, play-speed=(double)1, play-scale=(double)1
    /pipeline0/decodebin0.sink: caps = application/x-rtp, media=(string)audio, payload=(int)14, clock-rate=(int)90000, encoding-name=(string)MPA, npt-start=(guint64)0, npt-stop=(guint64)2783000000000, play-speed=(double)1, play-scale=(double)1
    /pipeline0/decodebin0.sink.proxypad0: caps = application/x-rtp, media=(string)audio, payload=(int)14, clock-rate=(int)90000, encoding-name=(string)MPA, npt-start=(guint64)0, npt-stop=(guint64)2783000000000, play-speed=(double)1, play-scale=(double)1
    /pipeline0/decodebin0/rtpmpadepay0.sink: caps = application/x-rtp, media=(string)audio, payload=(int)14, clock-rate=(int)90000, encoding-name=(string)MPA, npt-start=(guint64)0, npt-stop=(guint64)2783000000000, play-speed=(double)1, play-scale=(double)1
    /pipeline0/rtspsrc0.recv_rtp_src_1_3280887561_96: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)MP4V-ES, profile-level-id=(string)3, config=(string)00000120008687ffff088a8902180a31, npt-start=(guint64)0, npt-stop=(guint64)2783000000000, play-speed=(double)1, play-scale=(double)1
    /pipeline0/rtspsrc0.recv_rtp_src_1_3280887561_96.proxypad3: caps = application/x-rtp, media=(string)video, payload=(int)96, clock-rate=(int)90000, encoding-name=(string)MP4V-ES, profile-level-id=(string)3, config=(string)00000120008687ffff088a8902180a31, npt-start=(guint64)0, npt-stop=(guint64)2783000000000, play-speed=(double)1, play-scale=(double)1
    /pipeline0/decodebin0/mpegaudioparse0.src: caps = audio/mpeg, mpegversion=(int)1, layer=(int)3, rate=(int)48000, channels=(int)2, parsed=(boolean)true
    /pipeline0/decodebin0/mad0.sink: caps = audio/mpeg, mpegversion=(int)1, layer=(int)3, rate=(int)48000, channels=(int)2, parsed=(boolean)true
    /pipeline0/decodebin0/mad0.src: caps = audio/x-raw-int, endianness=(int)1234, signed=(boolean)true, width=(int)32, depth=(int)32, rate=(int)48000, channels=(int)2
    HATA: /pipeline0/rtspsrc0/udpsrc0 ğesinden: Internal data flow error.
    Ek hata ayıklama bilgisi:
    gstbasesrc.c(2165): gst_base_src_loop (): /pipeline0/rtspsrc0/udpsrc0:
    streaming task paused, reason not-linked (-1)
    Execution ended after 566526264 ns.
    Setting pipeline to PAUSED ...
    Setting pipeline to READY ...
    /pipeline0/decodebin0/mad0.src: caps = NULL
    /pipeline0/decodebin0/mad0.sink: caps = NULL
    /pipeline0/decodebin0/mpegaudioparse0.src: caps = NULL
    /pipeline0/decodebin0/rtpmpadepay0.sink: caps = NULL
    /pipeline0/decodebin0/typefind.src: caps = NULL
    /pipeline0/decodebin0/typefind.sink: caps = NULL
    /pipeline0/decodebin0.sink: caps = NULL
    /pipeline0/rtspsrc0.recv_rtp_src_1_3280887561_96: caps = NULL
    /pipeline0/rtspsrc0.recv_rtp_src_0_662345911_14: caps = NULL
    /pipeline0/rtspsrc0/rtpdec0.recv_rtp_src_1_3280887561_96: caps = NULL
    /pipeline0/rtspsrc0/rtpdec0.recv_rtp_src_0_662345911_14: caps = NULL
    Setting pipeline to NULL ...
    FREEING pipeline ...


    Could anybody help me about this?

  2. #2
    Just Joined!
    Join Date
    Sep 2010
    Posts
    4
    You can add the "-vvv" command to your pipeline:

    $ gst-launch playbin uri=rtsp://localhost:5554/Camera1 -vvv

    so this will display a lot of messages on screen and you will be able to know what elements does use playbin for build its internal pipeline.
    This can be useful for create a complete working pipeline and start to apply modifies.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •