Find the answer to your Linux question:
Results 1 to 8 of 8
Hi I'm a newbie to linux but eager to learn. Currently I'm installing Reqest-Tracker-3.6.6 and have problem in doing so. Here are the details. OS -- OpenSuse 10.3 . RT ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2008
    Posts
    5

    Unhappy Trouble in installing Request Tracker-3.6.6


    Hi

    I'm a newbie to linux but eager to learn. Currently I'm installing Reqest-Tracker-3.6.6 and have problem in doing so. Here are the details.

    OS -- OpenSuse 10.3 .
    RT -- Version is 3.6.6

    STEP:1 --> I xtracted the software in /tmp folder and ran the command ./configure. and it went smoothly.

    STEP:2 --> Then I ran the "make testdeps" as in the installation guide and it showed both missing and found dependencies.

    Bandtel2:/tmp/rt-3.6.6 # make testdeps
    /usr/bin/perl ./sbin/rt-test-dependencies --verbose --with-mysql
    perl:
    >=5.8.3(5.00800...found
    users:
    rt group (www)...found
    bin owner (root)...found
    libs owner (root)...found
    libs group (bin)...found
    web owner (nobody)...found
    web group (www)...found
    CLI dependencies:
    Term::ReadKey...found
    Getopt::Long >=2.24...found
    HTTP::Request::Common...found
    Term::ReadLine...found
    Text::ParseWords...found
    LWP...found
    CORE dependencies:
    Scalar::Util...found
    HTML::Scrubber >=0.08...found
    Class::ReturnValue >=0.40...found
    Text::Quoted 2.02...MISSING
    File::Spec >=0.8...found
    Calendar::Simple ...MISSING
    DBIx::SearchBuilder 1.50...MISSING
    Date::Format...found
    CSS::Squish 0.06...MISSING
    Text::Autoformat ...MISSING
    Mail::Mailer 1.57...MISSING
    Regexp::Common ...MISSING
    Module::Versions::Report 1.03...MISSING
    MIME::Entity 5.108...MISSING
    HTML::Entities...found
    Digest::MD5 >=2.27...found
    Cache::Simple::TimedExpiry ...MISSING
    DBI >=1.37...found
    Locale::Maketext::Lexicon 0.32...MISSING
    Digest::base...found
    Locale::Maketext::Fuzzy ...MISSING
    Time::HiRes...found
    Net::SMTP...found
    Text::Wrapper ...MISSING
    Time::ParseDate ...MISSING
    File::Temp...found
    Log:ispatch 2.0...MISSING
    Locale::Maketext >=1.06...found
    UNIVERSAL::require ...MISSING
    Tree::Simple 1.04...MISSING
    Text::Template ...MISSING
    MAILGATE dependencies:
    Pod::Usage...found
    HTML::TreeBuilder ...MISSING
    Getopt::Long...found
    HTML::FormatText ...MISSING
    LWP::UserAgent...found
    MASON dependencies:
    CGI::Cookie >=1.20...found
    Text::WikiFormat 0.76...MISSING
    XML::RSS 1.05...MISSING
    Storable >=2.08...found
    CSS::Squish 0.06...MISSING
    HTML::Mason 1.23...MISSING
    Apache::Session 1.53...MISSING
    Digest::MD5 >=2.27...found
    GD::Text ...MISSING
    GD ...MISSING
    Errno...found
    GD::Graph ...MISSING
    MYSQL dependencies:
    DBD::mysql 2.1018...MISSING

    SOMETHING WAS MISSING!
    Bandtel2:/tmp/rt-3.6.6 #
    ***********************************************

    STEP:3 --. I then started installing the wanted dependent modules one by one and got stuck in the installation of Text-Quoted-2.02

    --> It depends on Text::Autoformat 0 which I tried to install. As can be expected it in turn depends on Text-Reform.

    --> I installed Text-Reform-1.10 module which seems to be a success.
    **********************************************
    Bandtel2:/home/noc2/Desktop/Elango/RT-3.6.6/DEPENDENCIES/TEXT-REFORM/Text-Reform-1.10 # make install
    Installing /usr/lib/perl5/site_perl/5.8.8/Text/demo_columns.pl
    Installing /usr/lib/perl5/site_perl/5.8.8/Text/demo_ws.pl
    Installing /usr/lib/perl5/site_perl/5.8.8/Text/demo_filler.pl
    Installing /usr/lib/perl5/site_perl/5.8.8/Text/Reform.pm
    Installing /usr/lib/perl5/site_perl/5.8.8/Text/demo_table.pl
    Installing /usr/lib/perl5/site_perl/5.8.8/Text/demo.pl
    Installing /usr/share/man/man3/Text::Reform.3pm
    Writing /usr/lib/perl5/site_perl/5.8.8/i586-linux-thread-multi/auto/Text/Reform/.packlist
    Appending installation info to /usr/lib/perl5/5.8.8/i586-linux-thread-multi/perllocal.pod
    Bandtel2:/home/noc2/Desktop/Elango/RT-3.6.6/DEPENDENCIES/TEXT-REFORM/Text-Reform-1.10 #

    ******************************************
    --> But when I tried again to install the Text-Autoformat I got an error message which is pasted here for you view.

    noc2@Bandtel2:~/Desktop/Text-Autoformat-1.12> make test
    PERL_DL_NONLAZY=1 /usr/bin/perl "-Iblib/lib" "-Iblib/arch" test.pl
    1..1
    "break_at" is not exported by the Text::Reform module
    Can't continue after import errors at /usr/lib/perl5/site_perl/5.8.8/Text/Reform.pm line 43
    BEGIN failed--compilation aborted at blib/lib/Text/Autoformat.pm line 9.
    Compilation failed in require at test.pl line 13.
    BEGIN failed--compilation aborted at test.pl line 13.
    not ok 1
    make: *** [test_dynamic] Error 255


    --> I tried googling and tried to relplace the Reform.pm of Text-Reform 1.10 with the same version from CPAN and again with that of the Text-Reform-1.11 but failed on both occassion.

    ***********************

    I am blind from here and any help to proceed further would be appreciated

    Thanks and Regards
    mysuselove

  2. #2
    Linux Newbie
    Join Date
    Jun 2006
    Location
    Greece, Athens
    Posts
    214
    Have you tried installing it through YAST or with a precompiled package?

  3. #3
    Just Joined!
    Join Date
    Aug 2008
    Posts
    5
    Quote Originally Posted by kostasan View Post
    Have you tried installing it through YAST or with a precompiled package?
    Hi kostasan

    Thanks for your response.

    1. I didn't tried installing it through the YAST.
    2. I think it is not a pre-compiled package.

    * I went as per the installation guide which asked me to extract the tar file ( s/w ) to a temp folder and run the following commands.
    1. ./configure
    2. make testdeps
    3. if there are any wanted dependencies we may have to install either using the CPAN utility or manually . ( mostly perl & its modules, apache and mySQL or postgres SQL ).
    4. FYI I have pasted the README file below

    RT is an enterprise-grade issue tracking system. It allows organizations
    to keep track of what needs to get done, who is working on which tasks,
    what's already been done, and when tasks were (or weren't) completed.

    RT doesn't cost anything to use, no matter how much you use it; it
    is freely available under the terms of Version 2 of the GNU General
    Public License.

    RT is commercially-supported software. To purchase support, training,
    custom development, or professional services, please get in touch with
    us at sales@bestpractical.com.

    Jesse Vincent
    Best Practical Solutions, LLC
    March, 2005


    REQUIRED PACKAGES:
    ------------------

    o Perl 5.8.3 or later (Perl.com: The Source for Perl -- perl development, conferences).

    Perl versions prior to 5.8.3 contain bugs that could result
    in data corruption. We recommend strongly that you use 5.8.3
    or newer.

    o A supported SQL database

    Currently supported: Mysql 4.0.13 or later with InnoDB support.
    Postgres 7.2 or later.
    Oracle 9iR2 or later.
    SQLite 3.0. (Not recommended for production)

    o Apache version 1.3.x or 2.x (Welcome! - The Apache HTTP Server Project)
    with mod_perl -- (mod_perl: Welcome to the mod_perl world )
    or a webserver with FastCGI support (FastCGI Home)

    Compiling mod_perl on Apache 1.3.x as a DSO has been known
    to have massive stability problems and is not recommended.

    mod_perl 1.x must be built with EVERYTHING=1

    RT's FastCGI handler needs to access RT's configuration file.

    o Various and sundry perl modules
    A tool included with RT takes care of the installation of
    most of these automatically during the install process.

    The tool supplied with RT uses Perl's CPAN system
    (CPAN) to install modules. Some operating
    systems package all or some of the modules required, and
    you may be better off installing the modules that way.


    GENERAL INSTALLATION
    --------------------

    This is a rough guide to installing RT. For more detail, you'll
    want to read a more comprehensive installation guide at:

    InstallationGuides - RT Wiki

    1 Unpack this distribution other than where you want to install RT

    To do this cleanly, run the following command:

    tar xzvf rt.tar.gz -C /tmp

    2 Run the "configure" script.

    ./configure --help to see the list of options
    ./configure (with the flags you want)

    RT defaults to installing in /opt/rt3 with MySQL as its database. It
    tries to guess which of www-data, www, apache or nobody your webserver
    will run as, but you can override that behavior.

    3 Make sure that RT has everything it needs to run.

    Check for missing dependencies by running:

    make testdeps

    4 If the script reports any missing dependencies, install them by hand
    or run the following command as a user who has permission to install perl
    modules on your system:

    make fixdeps

    5 Check to make sure everything was installed properly.

    make testdeps

    It might sometimes be necessary to run "make fixdeps" several times
    to install all necessary perl modules.

    6 If this is a new installation:

    As a user with permission to install RT in your chosen directory, type:

    make install

    Set up etc/RT_SiteConfig.pm in your RT installation directory.
    You'll need to add any values you need to change from the defaults
    in etc/RT_Config.pm

    As a user with permission to read RT's configuration file, type:

    make initialize-database

    If the make fails, type:

    make dropdb

    and start over from step 6

    REST OF THE FILE ARE OMMITED FOR BREVITY

    ** > I did the ./configure cmd and tested the dependencies and the results are posted in the first thread which you might have gone through.

    ** > Is it possible to install thro YAST ? I doubt it.

    If you need further information , please let me know .

    Thanks and Regards
    mysuselove

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Jun 2006
    Location
    Greece, Athens
    Posts
    214
    I don't use openSuse, but i can install rt3.6 from the "YAST alternative" of my distribution. So there is 99% probability that you can install it from YAST. Open YAST, go to the section where you can install programs and search for rt or rt3.6 or something like this. YAST will take care of the rest.

  6. #5
    Just Joined!
    Join Date
    Aug 2008
    Posts
    5
    Hi kostasan

    Thanks for your suggestion .
    I tried using YAST and I am unable to search the rt3.6 using YAST. Nor was I able to find it in the Suse installation DVD. I tried importing the rt3.6 using the YAST from the extracted folder but unable to do so. since i am a newbie, I don't know how to point YAST to the rt package in the desktop, so that it could install automatically from local directory. Also the application package RT is not in RPM format.

    I appreciate your suggestion and thank you .Since you haven't used OpenSuse I don't know how you would give further suggestion if any.

    Thanks and Regards
    mysuselove

  7. #6
    Linux Newbie
    Join Date
    Jun 2006
    Location
    Greece, Athens
    Posts
    214
    Search for rt only and see if any package is the one you want. I suggest you ask on Suse forum how to install programs with YAST, they will help you much more than me.

  8. #7
    Just Joined!
    Join Date
    Aug 2008
    Posts
    5
    Hi kostasan

    I think I hit on the right track and will post you about the same in a few days . I appreciate your help.

    Thanks and regards
    mysuselove

  9. #8
    Just Joined!
    Join Date
    Aug 2008
    Posts
    5
    Hi

    I installed RT.
    I downloaded perl modules manually and installed one by one.
    Now i need to configure RT ( including mysql, apache etc ) so that i can have the GUI . I think its an uphill task since I don't know anything in perl , apache and other dependent s/w.
    Also make initialize-database command was not working properly because of USE mysql in Mysql not working properly. I'm stuck there. Do you have any idea to proceed form there

    Thanks and Regards
    mysuselove

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •