Find the answer to your Linux question:
Results 1 to 2 of 2
Evolution was working great for me until recently when it crashed out of the blue. Now when I launch evolution, it launches a bug-reporting too bug-buddy. If I cancel bugbuddy, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Posts
    1

    evolution woes: crashes on startup


    Evolution was working great for me until recently when it crashed out of the blue. Now when I launch evolution, it launches a bug-reporting too bug-buddy. If I cancel bugbuddy, evolution crashes. If I do "send" bug report in bug-buddy, it says,
    "999lease_try_with_newer_gnome" and evolution crashes.

    I did a "yum update gnome" but that did not resolve the issue.

    On the terminal I see the following messages.
    ------------------------------------------------
    [user1@xxx]$ evolution
    CalDAV Eplugin starting up ...
    ** (evolution:10680): DEBUG: mailto URL command: evolution --component=mail %s
    ** (evolution:10680): DEBUG: mailto URL program: evolution
    libnm_glib_dbus_init: error, org.freedesktop.DBus.Error.NoServer raised:
    Failed to connect to socket /var/run/dbus/system_bus_socket: Connection refused

    (evolution:10680): e-data-server-ui-DEBUG: ep_msg_send: in main thread? 0
    libnm_glib_dbus_init: error, org.freedesktop.DBus.Error.NoServer raised:
    Failed to connect to socket /var/run/dbus/system_bus_socket: Connection refused

    Backtrace limit of 200 exceeded
    /usr/share/bug-buddy/gdb-cmd:3: Error in sourced command file:
    Backtrace limit of 200 exceeded
    Backtrace limit of 200 exceeded
    libnm_glib_dbus_init: error, org.freedesktop.DBus.Error.NoServer raised:
    Failed to connect to socket /var/run/dbus/system_bus_socket: Connection refused

    libnm_glib_dbus_init: error, org.freedesktop.DBus.Error.NoServer raised:
    Failed to connect to socket /var/run/dbus/system_bus_socket: Connection refused

    (bug-buddy:10694): GLib-GObject-WARNING **: invalid uninstantiatable type `GParamChar' in cast to `GObject'
    --------------------


    However, when I log in as root, evolution startups up fine and does not crash.

    I have been trying "trial and error" ways to resolve this based on google search and so far been unsuccessful. Most recently I did "yum remove evolution-rspam" and that too was unsuccessful.

    I am using fedora7 and gnome 2.18.3.

    I will really really appreciate your help.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the forums!

    The following quick fix works for lots of apps, but I'm not sure about evolution:

    - close evolution
    - rename the evolution config folder(s)
    - restart evolution to allow the folder to rebuild itself

    Check the renamed folder for any data that you might need to reclaim before deleting it.

    I don't use evolution at all, so can't tell you what evolution folder(s) might need to be renamed. Perhaps someone that runs it can step in with some help should you be unable to figure it out on your own.

    Hope it works for you.
    oz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •