Find the answer to your Linux question:
Results 1 to 6 of 6
MPlayer is now taking a while to start a video file. It used to start almost straight away now there is a delay quite a few seconds. This has happened ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2008
    Posts
    91

    MPlayer is now slow to start up.


    MPlayer is now taking a while to start a video file. It used to start almost straight away now there is a delay quite a few seconds.

    This has happened to me before an annoyed to the point where I reinstalled the OS.

    My System is Ubuntu Hardy.
    Intel QX9770 (3.2GHz Dual core extreme quad)
    Corsair 4Gig 1600 (With extreme memory profiling)
    nVidia 9800 GX2 (Running in SLI)

    The computer as you can see is super fast and this should not be happening. Every thing else is running at normal speeds, applications and games such as ETQW and XPlane.

    The reason I love Linux is that when there is a problem when you find the cause (usally through a helpful community) it can be fixed with out much hassle.

    Thanks in advance.

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I'm finding this too, I don't use mplayer that much so I hadn't delved too deeply into it. I'd also be interested in any ideas here.

  3. #3
    Just Joined!
    Join Date
    Mar 2008
    Posts
    91
    I am thinking of reinstalling AGAIN! but a solution would be great!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2009
    Location
    Singapore
    Posts
    1

    Solution

    Hi vh-bil,

    Please don't reinstall! I'm not sure if you've trained that reflex by many years of Windows using, but you should try to suppress it as a Linux user .

    I had the same problem recently, and found that the problem is that mplayer is attempting to disable your screensaver, and whilst attempting to do so, it blocks.

    We can direct mplayer to not try this, by:
    Add this to ~/.mplayer/config:
    stop-xscreensaver = no
    And modify the entry in ~/.mplayer/gui.conf:
    stopxscreensaver="no"
    There's a little more info on my blog post, but the above should be all you need.

    Best regards,
    Juicy Data

  6. #5
    Just Joined!
    Join Date
    Mar 2008
    Posts
    91
    Quote Originally Posted by juicydata_09 View Post
    Hi vh-bil,

    Please don't reinstall! I'm not sure if you've trained that reflex by many years of Windows using, but you should try to suppress it as a Linux user .

    I had the same problem recently, and found that the problem is that mplayer is attempting to disable your screensaver, and whilst attempting to do so, it blocks.

    We can direct mplayer to not try this, by:


    There's a little more info on my blog post, but the above should be all you need.

    Best regards,
    Juicy Data
    It is pepople like you that make the Linux community what it is! Thanks...

    I LoVe lInuX

    EDIT: I just noticed it is your first post too! Well Done!

  7. #6
    Just Joined!
    Join Date
    Nov 2009
    Posts
    1
    I had the same problem, and the same fix worked! Thanks!
    The strange thing is, the problem manifested itself when I installed PulseAudio. Never had this problem before...
    -------------------------------
    MPlayer 1.0rc2-4.3.3
    Kubuntu 9.04 Jaunty, kernel 2.6.28-11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •