Find the answer to your Linux question:
Results 1 to 5 of 5
I'm trying to install inkscape on slackware 12.2. It requires installing libgc: Code: checking libgc version 6.4+... no configure: error: libgc (the Boehm Conservative Collector) 6.4+, is needed to compile ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Feb 2009
    Posts
    104

    libgc misssing?!


    I'm trying to install inkscape on slackware 12.2. It requires installing libgc:
    Code:
    checking libgc version 6.4+... no
    configure: error: libgc (the Boehm Conservative Collector) 6.4+, is needed to compile inkscape -- http://www.hpl.hp.com/personal/Hans_Boehm/gc
    I downloaded libgc6.8 from the above mentioned website and everything compiled without errors, however if I try to install inkscape I still get the same error that libgc is missing. How can I solve it ? Do I need to do anything with 'ld'?


    Libgc is present on my system:

    Code:
    /usr/local/lib/libgc.so.1.0.2
    /usr/local/lib/libgc.so
    /usr/local/lib/libgc.so.1
    /usr/local/lib/libgc.la
    /usr/local/lib/libgc.a

    thanks

  2. #2
    Linux Newbie
    Join Date
    Feb 2009
    Location
    Third ring of Pergatory
    Posts
    199
    I don't think libgc is missing Portia, it's more likely it's installed outside the $PATH environmental variable (either in inkscape or on your system).
    Start like this. First we're going to find every instance of libgc on your computer.
    As root or a user with root-like priveledges
    Code:
    find / | grep -i libgc.  > where_is_the_lib
    of course, your welcome to use whatever filenames you like
    Next, same user
    Code:
     echo $PATH >> where_is_the_lib
    Now in a text editor open where_is_the_lib. Every line that contains "libgc" is a location where the library might be, a line that ends in "glibc*.so* is what your looking for.
    The bottom couple of lines are where your machines looking for these files.
    You'll see right away what directories you have to add to the environmental variable PATH or conversely where you should reinstall the libs.
    Easy to modify the PATH but doing it routinely is bad practice.
    Better to move the libs but your a noob and I don't want to overwhelm you.
    Let me know if you need help.

  3. #3
    Linux Newbie
    Join Date
    Feb 2009
    Posts
    104
    As far as I know the standard $PATH does not play any role in linking libraries while compiling. It's weird as /usr/local/lib (that's where the libgc is) exists in /etc/ld.so.conf.
    BTW, LD_LIBRARY_PATH is empty. When I try to set it up, it gives me an error:
    # LD_LIBRARY_PATH=/usr/local/lib
    # export $LD_LIBRARY_PATH
    bash: export: `/usr/local/lib': not a valid identifier
    Any hints

  4. #4
    Linux Newbie
    Join Date
    Feb 2009
    Location
    Third ring of Pergatory
    Posts
    199
    did you try
    #LD_LIBRARY_PATH=/usr/local/lib:
    or
    #LD_LIBRARY_PATH=/usr/local/lib/:
    Path always wants directories, it may think your naming a particular file without the : or trailing /
    I hereby withdraw the prior noob comment, btw, sorry.

  5. #5
    Linux Newbie
    Join Date
    Feb 2009
    Posts
    104
    Actually I updated the library path with ldconfig and everything is ok. I don't know why it wasn't updated.

    Quote Originally Posted by dijetlo View Post
    I hereby withdraw the prior noob comment, btw, sorry
    No worries

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •