Find the answer to your Linux question:
Results 1 to 1 of 1
I am using digikam 0.9.1 on Ubuntu 7.04 with the gnome desktop. It was working ok until I totally reconfigured my hard disk where the photos were. Digikam had trouble ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! measekite's Avatar
    Join Date
    Mar 2009
    Posts
    52

    Thumbs up digikam database crash


    I am using digikam 0.9.1 on Ubuntu 7.04 with the gnome desktop.

    It was working ok until I totally reconfigured my hard disk where the photos were. Digikam had trouble updating the removal and additions of folders.

    It crashed.

    I could not get it started again. I uninstalled using complete removal via synaptic and then did a clean installation.

    When I try to ipl digikam I get the following error:

    Failed to update old database to new database format.

    I have tried everything i am aware of. Apparently I am assuming that digikam was never totally wiped out clean even though I rebooted after I did the removal.

    To me it looks like the old db is still on the disk or some other file and I cannot find it.

    It seems that kde and its applications have more issues than gnome application. Maybe because they just try to do too much.

    While gThumb has very little in the way of features I never had a problem with it. It is just that simple with not db etc.

    Does anybody know how I can totally wipe out everything to do with digikam short of getting rid of kde since I am using a few other kde apps like k3b or what I need to do to get it going again?

    Here is how I solved the problem.

    Booted Windows
    Ran CheckDisk /f
    found and fixed a bunch of bad segments
    Deleted the bad corrupt file
    Ran DeFrag
    really did not need to but it did improve performance unexpectedly
    ShutDown Windows
    Booted Linux

    This was an ntfs drive so I felt better using chkcsk /f in Windows instead of fsck -v in Linux.
    It appears I had two issues. Corrupt DB Journal and bad segments somewhere


    Last edited by measekite; 03-31-2009 at 01:05 AM. Reason: [SOLVED] Posted Solution for Others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •