I am new to linux and decided to have a go at installing an application from source (Glame 1.0.2)

A week later and I am starting to regret this decision. I have got most of the way there (I hope) but am stuck with getting the Gnome libs installed.

It wont compile I keep getting errors in gnome-metadata.c file with various functions. I have looked the errors up in a search and found somthing about needed DB-3.3.11 installed with 1.8.5 compatability so I have tried this but with no joy.

How can I tell if I have DB-3.3.11 installed correctly?

Please Please can someone help!