Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all, trying to install xnest in Slax distro. root@slax:/usr# Xnest :1 -query 192.168.0.2 -nolisten inet6 XDMCP warning: INET6 UDP socket creation failed Could not init font path element /usr/share/fonts/OTF, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2009
    Posts
    2

    Unhappy Xnest not working (missing fonts)


    Hi all,

    trying to install xnest in Slax distro.

    root@slax:/usr# Xnest :1 -query 192.168.0.2 -nolisten inet6

    XDMCP warning: INET6 UDP socket creation failed
    Could not init font path element /usr/share/fonts/OTF, removing from list!
    Could not init font path element /usr/share/fonts/Type1, removing from list!

    Fatal server error:
    could not open default font 'fixed'

    I indeed could not find any OTF and TYPE1 fonts in this distro. There is only :
    root@slax:/usr/share/fonts# ls
    75dpi/ TTF/ misc/ override/

    Could any of you have this kind of problems and could point out what I possibly should have done?


    Thank you so much

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    Quote Originally Posted by mitzelburg View Post
    Hi all,

    trying to install xnest in Slax distro.

    root@slax:/usr# Xnest :1 -query 192.168.0.2 -nolisten inet6

    XDMCP warning: INET6 UDP socket creation failed
    Could not init font path element /usr/share/fonts/OTF, removing from list!
    Could not init font path element /usr/share/fonts/Type1, removing from list!

    Fatal server error:
    could not open default font 'fixed'
    Being unable to find "fixed" is what's killing the server, probably. I don't know why xnest failst at this though. I suggest using Xephir instead, which is better maintained and up to date feature-wise.

    I indeed could not find any OTF and TYPE1 fonts in this distro. There is only :
    root@slax:/usr/share/fonts# ls
    75dpi/ TTF/ misc/ override/
    These two are normal warnings and do not mean any harm.

  3. #3
    Just Joined!
    Join Date
    Apr 2009
    Posts
    2
    Quote Originally Posted by i92guboj View Post
    Being unable to find "fixed" is what's killing the server, probably. I don't know why xnest failst at this though. I suggest using Xephir instead, which is better maintained and up to date feature-wise.
    Yes, unfortunately, I do not know how to get a Xephyr (.tar.gz). I have read in several articels, telling me to install XORG.

    I have already got an XORG default in the distro, however, i can not execute Xephyr.. Do you possibly have any idea in installing Xephyr in a non debian-ubuntu based distro ? (I am using slax)

    thank you

  4. #4
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    I Gentoo we need to set the kdrive use flag when compiling xorg. So maybe looking around for kdrive will give you some result. I have no specific idea about slax, sorry.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •