Find the answer to your Linux question:
Results 1 to 5 of 5
I just installed Suse 8.2 Pro (I'm impressed so far!), and the only thing I have had a problem with so far is running programs from the console. (I use ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2003
    Posts
    6

    Run programs from Konsole


    I just installed Suse 8.2 Pro (I'm impressed so far!), and the only thing I have had a problem with so far is running programs from the console. (I use the KDE Konsole)

    I like to SU then type konqueror so I can easily modify Admin privelage files without having to logout and log back in. But when I SU and type konqueror, it says bash: konqueror: command not found. What should I do?

    NOTE: It works just fine when I try typing konqueror or some other program in Konsole if I don't SU before I try running the command. (For example I can just pop up a Konsole window logged in as a normal user and type konqueror and it comes up)[/i]

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    As a normal user, run "which konqueror", and then run "echo $PATH" as root. Then post the output of those commands here.
    You can also, of course, just edit the files with normal shell commands without resorting to the GUI, but I would agree that the problem should still be solved, not worked around.

  3. #3
    Just Joined!
    Join Date
    May 2003
    Posts
    6
    Exdaix@Exdaix:~> which konqueror
    /opt/kde3/bin/konqueror
    Exdaix@Exdaix:~> su
    Password:
    Exdaix:/home/Exdaix # echo $PATH
    /usr/sbin:/bin:/usr/bin:/sbin:/usr/X11R6/bin
    Exdaix:/home/Exdaix #

    From that I see my /opt/kde/bin/ folder needs to be put in my root PATH statement. I am still rather a Linux noobie, so I am unsure as to how go about fixing this.

    Thanks for your help so far.

  4. #4
    Just Joined!
    Join Date
    May 2003
    Posts
    6
    Ok, I found a tutorial on how to add a directory to your PATH. I did it correctly and I tried typing in konqueror and I get the folowing:

    Exdaix:/home/Exdaix # konqueror
    Xlib: connection to ":0.0" refused by server
    Xlib: No protocol specified

    konqueror: cannot connect to X server :0.0
    Exdaix:/home/Exdaix #

  5. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    In that case, you don't have the pam_xauth PAM module installed. The manual workaround for that is to create a symlink named /root/.Xauthority pointing to your user's .Xauthority file. If I'm correct about your system, you would do that by running this:
    Code:
    ln -s /home/Exdaix/.Xauthority /root/.Xauthority

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •