Find the answer to your Linux question:
Results 1 to 3 of 3
Easytag keeps deleting my files. It used to work fine, but now, when renaming files, it'll rename the first file, then throw errors on the rest. These errors come up ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2009
    Location
    Honolulu
    Posts
    1

    EasyTag 2.1 deletes files


    Easytag keeps deleting my files. It used to work fine, but now, when renaming files, it'll rename the first file, then throw errors on the rest. These errors come up because they've all disappeared from the original folder. They've disappeared from the drive entirely, in fact. They can't even be located with various deleted-file-recovery software I have.

    It seems that easytag, when changing the filename of the first file, it changes the folder name instead of rewriting to the new folder. That still doesn't really explain why they disappear, they should show up there still, but that's the best I can come up with.

    I was using openSUSE 11.1 when easytag worked fine. I reformatted to try out PCLinuxOS 2009.1, and that's when I started getting this problem. I've reformatted yet again, going back to openSUSE (just because of this problem). I still have this problem. Luckily, everything it deletes is replaceable, but it's still a serious pain and very frustrating. Can anyone suggest the cause or a solution? I haven't found a tagger I like as much as Easytag.

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    I think it would help if you posted some of the error messages. Are you trying to rename files and copy to another folder?

    Might be useful to post examples of the filename you are trying to rename.

  3. #3
    Linux Guru
    Join Date
    Nov 2007
    Location
    Córdoba (Spain)
    Posts
    1,513
    We would need to see the error messages. You should also run it from a terminal, so you can see any debug message that it spits out there.

    But before continuing, I suggest you to umount the drive where those files live and check the whole volume with fsck. Easytag is pretty robust in my experience so there's a chance that the problem is at a lower level, and the fs is always a good candidate for file corruption.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •