I was having some trouble loading graphics into a particular app and determined from reading forums that the problem is outdated GL drivers (apparently certain graphics card manufacturers still ship with outdated GL drivers). The GL driver manufacturer is Mesa3d, I have downloaded the source along with all of the dependencies that are listed online. I am having trouble installing the dependencies however. The dependencies are dri2proto, libpthread-stubs, and libdrm. libpthread-stubs is required for libdrm. When I run the command line "make install" for libpthread-stubs I am told that all of the necessary files are created, but when I execute "./configure" for libdrm it says:

"
No package 'pthread-stubs' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PTHREADSTUBS_CFLAGS
and PTHREADSTUBS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
"

I have also tried running the commands:
export PKG_CONFIG_PATH="/usr/local/lib/pkgconfig"
export LD_LIBRARY_PATH=/usr/local/lib

I wasn't able to find any help online with this issue and cannot install the updated Mesa3d GL drivers without it. If anyone is aware of a solution, please let me know. Thank-you for your help.