Find the answer to your Linux question:
Results 1 to 2 of 2
There's now a firefox/ folder in /opt/. I've put the file firefox.bin into /usr/bin with the name `firefox', and now there's a firefox command, but when using it i get: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2009
    Posts
    26

    Installed Firefox from source, problems...


    There's now a firefox/ folder in /opt/.
    I've put the file firefox.bin into /usr/bin with the name `firefox', and now there's a firefox command, but when using it i get:
    Code:
    firefox: error while loading shared libraries: libxul.so: cannot open shared object file: No such file or directory
    I don't want to enter /opt/firefox/firefox each time i want to run FF. =P Don't necessarily need a desktop shortcut though, first a CLI command.


    Other problems:
    Installing from source seems to cause it loose `synch' with the OS...
    When installing extensions and clicking `Restart Firefox', it shuts down but doesn't restart, and manually restarting does not install the extensions either.
    Other than that, when i choose `Open download folder' of downloads (from the download manager), it asks for what program to use (and i cannot find Konqueror, but it shouldn't ask in first place). It also asks for what program to use when i simply try to `Open' a downloaded file.
    Another thing drawing my attention is that i get a hell lot of warnings and messages in the Error Console, and ocassionally errors, but that might be normal, dunno. What i know to be abnormal is that every once in a while, while surfing, pages suddenly stop loading at all, and this fixes itself after a minute or so maybe. It's extremely annoying though, when it happens.


    EDIT: After a reboot, the plugins seem to have been installed, and even the `Restard Firefox' button works now. But the rest of the problems remain.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    If you don't need a system wide (for all users) install of Firefox, you can download the file, extract it, and then drop the entire thing into your home directory and run it from there by clicking on the firefox executable. I used to run it that way all the time and all plugins and other add-ons worked fine.
    oz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •