Find the answer to your Linux question:
Results 1 to 5 of 5
I am trying to compile Conky 1.7.2 on my openSUSE machine and it has been a real pain in the rear. I've resolved several dependencies already but now my current ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! KPolulak's Avatar
    Join Date
    Feb 2009
    Location
    New Jersey, USA
    Posts
    42

    Issues While Compiling Conky


    I am trying to compile Conky 1.7.2 on my openSUSE machine and it has been a real pain in the rear. I've resolved several dependencies already but now my current error is this when running "make":

    Code:
    kevin@kevin-suse:/usr/local/sbin/conky-1.7.2> sudo make
    Making all in src
    make[1]: Entering directory `/usr/local/sbin/conky-1.7.2/src'
    make  all-am
    make[2]: Entering directory `/usr/local/sbin/conky-1.7.2/src'
    gcc -DHAVE_CONFIG_H -I. -DSYSTEM_CONFIG_FILE=\"/usr/local/etc/conky/conky.conf\" -DPACKAGE_LIBDIR=\"/usr/local/lib/conky\"   -I/usr/include/lua5.1       -I/usr/include/freetype2   -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include   -Wall -W  -MT conky-conf_cookie.o -MD -MP -MF .deps/conky-conf_cookie.Tpo -c -o conky-conf_cookie.o `test -f 'conf_cookie.c' || echo './'`conf_cookie.c
    mv -f .deps/conky-conf_cookie.Tpo .deps/conky-conf_cookie.Po
    gcc -DHAVE_CONFIG_H -I. -DSYSTEM_CONFIG_FILE=\"/usr/local/etc/conky/conky.conf\" -DPACKAGE_LIBDIR=\"/usr/local/lib/conky\"   -I/usr/include/lua5.1       -I/usr/include/freetype2   -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include   -Wall -W  -MT conky-colours.o -MD -MP -MF .deps/conky-colours.Tpo -c -o conky-colours.o `test -f 'colours.c' || echo './'`colours.c
    In file included from conky.h:111,
                     from colours.c:29:
    llua.h:25:17: error: lua.h: No such file or directory
    llua.h:26:21: error: lauxlib.h: No such file or directory
    llua.h:27:20: error: lualib.h: No such file or directory
    make[2]: *** [conky-colours.o] Error 1
    make[2]: Leaving directory `/usr/local/sbin/conky-1.7.2/src'
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/usr/local/sbin/conky-1.7.2/src'
    make: *** [all-recursive] Error 1
    kevin@kevin-suse:/usr/local/sbin/conky-1.7.2>
    Not sure if this is important but here is the output from the ./configure command:

    Code:
    kevin@kevin-suse:/usr/local/sbin/conky-1.7.2> sudo ./configure
    root's password:
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc3
    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking for a sed that does not truncate output... /bin/sed
    checking for grep that handles long lines and -e... /bin/grep
    checking for egrep... /bin/grep -E
    checking for fgrep... /bin/grep -F
    checking for ld used by gcc... /usr/i586-suse-linux/bin/ld
    checking if the linker (/usr/i586-suse-linux/bin/ld) is GNU ld... yes
    checking for a BSD-compatible install... /usr/bin/install -c
    checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
    checking the name lister (/usr/bin/nm -B) interface... BSD nm
    checking whether ln -s works... yes
    checking the maximum length of command line arguments... 1572864
    checking whether the shell understands some XSI constructs... yes
    checking whether the shell understands "+="... yes
    checking for /usr/i586-suse-linux/bin/ld option to reload object files... -r
    checking for objdump... objdump
    checking how to recognize dependent libraries... pass_all
    checking for ar... ar
    checking for strip... strip
    checking for ranlib... ranlib
    checking command to parse /usr/bin/nm -B output from gcc object... ok
    checking how to run the C preprocessor... gcc -E
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking for dlfcn.h... yes
    checking for objdir... .libs
    checking if gcc supports -fno-rtti -fno-exceptions... no
    checking for gcc option to produce PIC... -fPIC -DPIC
    checking if gcc PIC flag -fPIC -DPIC works... yes
    checking if gcc static flag -static works... yes
    checking if gcc supports -c -o file.o... yes
    checking if gcc supports -c -o file.o... (cached) yes
    checking whether the gcc linker (/usr/i586-suse-linux/bin/ld) supports shared libraries... yes
    checking whether -lc should be explicitly linked in... no
    checking dynamic linker characteristics... GNU/Linux ld.so
    checking how to hardcode library paths into programs... immediate
    checking whether stripping libraries is possible... yes
    checking if libtool supports shared libraries... yes
    checking whether to build shared libraries... yes
    checking whether to build static libraries... yes
    checking whether gcc and cc understand -c and -o together... yes
    checking for pkg-config... yes
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.19... yes
    checking for fopencookie... yes
    checking for funopen... no
    checking for X11... yes
    checking for LUA... no
    checking for LUA51... no
    checking for LUA51... yes
    checking for getnameinfo... yes
    checking netdb.h usability... yes
    checking netdb.h presence... yes
    checking for netdb.h... yes
    checking netinet/in.h usability... yes
    checking netinet/in.h presence... yes
    checking for netinet/in.h... yes
    checking netinet/tcp.h usability... yes
    checking netinet/tcp.h presence... yes
    checking for netinet/tcp.h... yes
    checking sys/socket.h usability... yes
    checking sys/socket.h presence... yes
    checking for sys/socket.h... yes
    checking arpa/inet.h usability... yes
    checking arpa/inet.h presence... yes
    checking for arpa/inet.h... yes
    checking for ld used by GCC... /usr/i586-suse-linux/bin/ld
    checking if the linker (/usr/i586-suse-linux/bin/ld) is GNU ld... yes
    checking for shared library run path origin... done
    checking for iconv... yes
    checking for working iconv... yes
    checking for iconv declaration...
             extern size_t iconv (iconv_t cd, char * *inbuf, size_t *inbytesleft, char * *outbuf, size_t *outbytesleft);
    checking for Xext... yes
    checking for XDamage... yes
    checking for Xft... yes
    checking for GLib2... yes
    checking alsa/asoundlib.h usability... no
    checking alsa/asoundlib.h presence... no
    checking for alsa/asoundlib.h... no
    checking signal.h usability... yes
    checking signal.h presence... yes
    checking for signal.h... yes
    checking for unistd.h... (cached) yes
    checking sys/utsname.h usability... yes
    checking sys/utsname.h presence... yes
    checking for sys/utsname.h... yes
    checking for sys/stat.h... (cached) yes
    checking linux/soundcard.h usability... yes
    checking linux/soundcard.h presence... yes
    checking for linux/soundcard.h... yes
    checking for alsa/asoundlib.h... (cached) no
    checking dirent.h usability... yes
    checking dirent.h presence... yes
    checking for dirent.h... yes
    checking mcheck.h usability... yes
    checking mcheck.h presence... yes
    checking for mcheck.h... yes
    checking sys/statfs.h usability... yes
    checking sys/statfs.h presence... yes
    checking for sys/statfs.h... yes
    checking sys/param.h usability... yes
    checking sys/param.h presence... yes
    checking for sys/param.h... yes
    checking pthread.h usability... yes
    checking pthread.h presence... yes
    checking for pthread.h... yes
    checking assert.h usability... yes
    checking assert.h presence... yes
    checking for assert.h... yes
    checking errno.h usability... yes
    checking errno.h presence... yes
    checking for errno.h... yes
    checking time.h usability... yes
    checking time.h presence... yes
    checking for time.h... yes
    checking for sys/mount.h... yes
    checking sys/inotify.h usability... yes
    checking sys/inotify.h presence... yes
    checking for sys/inotify.h... yes
    checking for calloc... yes
    checking for malloc... yes
    checking for free... yes
    checking for popen... yes
    checking for sysinfo... yes
    checking for getloadavg... yes
    checking for memrchr... yes
    checking for strndup... yes
    checking for gethostbyname_r... yes
    checking for library containing clock_gettime... -lrt
    checking for struct statfs.f_fstypename... no
    checking zlib.h usability... yes
    checking zlib.h presence... yes
    checking for zlib.h... yes
    checking for db2x_xsltproc... no
    checking for db2x_manxml... no
    checking for xsltproc... xsltproc
    checking if /usr/i586-suse-linux/bin/ld accepts -O1... yes
    configure: creating ./config.status
    config.status: creating Makefile
    config.status: creating data/Makefile
    config.status: creating doc/Makefile
    config.status: creating src/Makefile
    config.status: creating src/build.h
    config.status: creating lua/Makefile
    config.status: creating src/config.h
    config.status: executing depfiles commands
    config.status: executing libtool commands
    
    conky 1.7.2 configured successfully:
    
     Installing into:   /usr/local
     System config dir: ${prefix}/etc
     C compiler flags:      -I/usr/include/lua5.1       -I/usr/include/freetype2   -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include   -Wall -W
     Libraries:          -lm -lX11    -llua5.1    -lXext   -lXdamage -lXfixes   -lXft -lXrender -lfontconfig -lfreetype -lz -lX11   -L/usr/local/lib -lglib-2.0   -lrt
     Linker flags:       -Wl,-O1
    
     * X11:
      X11 support:      yes
      XDamage support:  yes
      XDBE support:     yes
      Xft support:      yes
    
     * Music detection:
      Audacious:        no
      BMPx:             no
      MPD:              yes
      MOC:              yes
      XMMS2:            no
    
     * General:
      OpenMP:
      math:             yes
      hddtemp:          yes
      portmon:          yes
      RSS:              no
      Curl:             no
      Weather
        METAR:          no
        XOAP:           no
      wireless:         no
      IBM:              no
      nvidia:           no
      eve-online:       no
      config-output:    yes
      Imlib2:           no
      ALSA mixer:       no
      apcupsd:          yes
      I/O stats:        yes
    
     * Lua (yes) bindings:
      Cairo:            no
      Imlib2:           no
    
    kevin@kevin-suse:/usr/local/sbin/conky-1.7.2>

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Why don't you install conky with your package manager? I'm sure it is available on the SUSE repos.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined! KPolulak's Avatar
    Join Date
    Feb 2009
    Location
    New Jersey, USA
    Posts
    42
    Actually, I can't seem to find it. I've been using Debian for quite a while but I'm new to SUSE so I'm a little unsure of how I'd modify the file containing what repositories zypper should check.

    I'd rather compile it because, lately, I've been compiling any needed software manually because I want to become more familiar with the process and be able to recognize certain errors and how to handle them, etc.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    First thing, you shouldn't run ./configure and make with sudo. These steps should be done as a regular user.

    EDIT: make install does need to be done as root, though.

    I don't know Suse well, but according to the Arch PKGBUILD script, these are the dependencies:

    alsa-lib
    curl
    glib2
    imlib2
    libxdamage
    libxft
    libxml2
    lua
    wireless_tools


    Names may be slightly different in Suse.

    llua.h:25:17: error: lua.h: No such file or directory
    Looks to me like you're missing lua.

  6. #5
    Just Joined! KPolulak's Avatar
    Join Date
    Feb 2009
    Location
    New Jersey, USA
    Posts
    42
    The weird thing is I do have it installed. Before I had this issue, I had the same error message except it referred to lua5.1. I remembered having the same problem while compiling Conky on my Debian machine and I remember why but forgot how I solved it. Apparently, lua doesn't install a pkg-config .pc file. I looked online but couldn't find much help so I just copied the lua5.1.pc, lua50.pc, and lualib50.pc files on my Debian machine to the same directory on my SUSE machine and the error message disappeared.

    I'm not sure if this'll help, but I just noticed that I do indeed have a glib-2.0.pc file in the /usr/local/lib/pkgconfig/ directory on my SUSE machine.

    Also, yes I do need to use the sudo command because I extracted the files in the /usr/local/sbin/ directory which is owned by the root user.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •