Hi im trying to install grub 2 on my Linux from scratch.
but when i reboot i get Operating System not found
What should i do now?

the script looks like this:
============== grub.cfg begin ========================
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
set default=0
set timeout=5
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "GNU/Linux, Linux 2.6.30.2" {
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set e4adbac2-a338-4305-bafe-73f2adb307da
linux /boot/vmlinux-2.6.30.2 root=/dev/sda1 ro
}
menuentry "GNU/Linux, Linux 2.6.30.2 (recovery mode)" {
insmod ext2
set root=(hd0,1)
search --no-floppy --fs-uuid --set e4adbac2-a338-4305-bafe-73f2adb307da
linux /boot/vmlinux-2.6.30.2 root=/dev/sda1 ro single
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries. Simply type the
# menu entries you want to add after this comment. Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###
=============== grub.cfg end =======================

This is my fstab
=============== /etc/fstab begin ===================
# Begin /etc/fstab
# file system mount-point type options dump fsck
# order
/dev/sda1 / ext3 defaults 1 1
/dev/sda2 swap swap pri=1 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
devpts /dev/pts devpts gid=4,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
# End /etc/fstab
=============== /etc/fstab end ======================

fdisk -l
================================================== ===
Device Boot Start End Blocks Id System
/dev/sda1 * 1 487 3911796 83 Linux
/dev/sda2 488 549 498015 82 Linux Swap / Solaris
/dev/sda3 550 1044 3976087+ 83 Linux

Thanks
//Sinnes