Find the answer to your Linux question:
Results 1 to 9 of 9
OpenOffice can't read the documents and spreadsheets from my NAS. When I double click on such a document openOffice starts loading but it hags before the application opens. However, when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    163

    [SOLVED] HELP! openOffice hangs on NAS


    OpenOffice can't read the documents and spreadsheets from my NAS. When I double click on such a document openOffice starts loading but it hags before the application opens.
    However, when I copy the same document from the NAS to my local disk, it opens the document without problems (i.e. the document is not corrupted).

    I mount my NAS in fstab as follows.
    Code:
    192.168.1.220:/mnt/HD_a2/DATA /mnt/NASdata nfs defaults 0 0
    I'm the owner of all documents and spreadsheets on the NAS.
    Code:
    chown -R boris:users *
    I also opened all document/folder rw permissions for user, group and world.
    Code:
    chmod -R 777 *
    I have no clue what else to do.

    Why OO still can't open any files on the NAS?
    Any suggestions please!
    Fedora20.GNOME@Dell_Latitude_E6410
    Fedora14.GNOME@HP_Compaq_DC7100

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    What is the make+model of your NAS? Also, does it have a Samba server so you can use CIFS instead of NFS to access the files?
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    163
    It's a Conceptronic CH3SNAS.

    Yes it has a Samba server. Good idea, I shall try it.
    However, I'm not in favor of using CIFS because it requires user name and password (I don't like the idea of showing my passwords in the fstab). Still I can try to see if OO stumbles over the same problem.
    Fedora20.GNOME@Dell_Latitude_E6410
    Fedora14.GNOME@HP_Compaq_DC7100

  4. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    Quote Originally Posted by blnl View Post
    It's a Conceptronic CH3SNAS.

    Yes it has a Samba server. Good idea, I shall try it.
    However, I'm not in favor of using CIFS because it requires user name and password (I don't like the idea of showing my passwords in the fstab). Still I can try to see if OO stumbles over the same problem.
    That's kind of what I was getting at - if OOo has a problem when the file system is mounted that way instead of NFS. If not, then I can only think it is something to do with NFS file/directory permissions. I fully understand your issue regarding name/password exposure in fstab. Myself, I allow cifs mounts on a per-user basis (not system) so that each user can only mount what I permit them. A shell script can ask them for their CIFS password when it does the mount.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  5. #5
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    Anyway, I'm not familiar with that make/model of NAS. I have a couple of TeraStation units myself, and they use CIFS/Samba, no NFS, even though they use Linux for the box OS w/ xfs file systems.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  6. #6
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    163
    Eventually, I found some time to experiment with Samba.
    The good news is that OO does not hang when I mount the drive with CIFS.

    However, there is another problem that I'm facing.
    Each time I open OO document (by clickin on it), the following message pops up:

    I'm confused why OO does not recognize its own file format any more. Still, when I click on "Display" button, OO opens the file.

    I also notice that new OO files that I saved on the disk during this experiment did not get the proper user:group attributes.
    Code:
    -rwxrwxrwx 1   504   702 18269 2009-12-21 23:58 TestDoc.ods
    What is this 504 702 meaning?
    Although having root privileges, I was not able to change the user:group of this file.
    Code:
    linux-uswz:/mnt/temp # chown boris:users TestDoc.ods 
    chown: changing ownership of `TestDoc.ods': Permission denied
    This is how I mount the drive:
    Code:
    mount.cifs //192.168.1.220/FILES /mnt/temp/ -o user=*****,password=*****
    Why CIFS messes with my user:group attributes?
    Any suggestions how to addrss this issue?

    Besides gedit also has some issues when saving the files with Ctrl+S. The following messge appears:
    Fedora20.GNOME@Dell_Latitude_E6410
    Fedora14.GNOME@HP_Compaq_DC7100

  7. #7
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    163
    When I open an OO document on another Linux computer (with NFS server), OO does not hang. I also noticed that OO creates a locked version of the document on the disk.
    This is where it goes wrong with my NAS, OO is not able to create locked version of the document on the NAS.

    I tried changing /etc/export settings on the NAS to be the same as on that other Linux machine.
    Code:
    /mnt/HD_a2 192.168.1.0/24(rw,no_root_squash,sync,no_subtree_check)
    It still does not work.

    At this point I suspect that there is something wrong with the NFS implementation of my NAS.
    I shall try upgrading the firmware.
    Fedora20.GNOME@Dell_Latitude_E6410
    Fedora14.GNOME@HP_Compaq_DC7100

  8. #8
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,380
    Quote Originally Posted by blnl View Post
    Eventually, I found some time to experiment with Samba.
    The good news is that OO does not hang when I mount the drive with CIFS.

    However, there is another problem that I'm facing.
    Each time I open OO document (by clickin on it), the following message pops up:

    I'm confused why OO does not recognize its own file format any more. Still, when I click on "Display" button, OO opens the file.

    I also notice that new OO files that I saved on the disk during this experiment did not get the proper user:group attributes.
    Code:
    -rwxrwxrwx 1   504   702 18269 2009-12-21 23:58 TestDoc.ods
    What is this 504 702 meaning?
    Although having root privileges, I was not able to change the user:group of this file.
    Code:
    linux-uswz:/mnt/temp # chown boris:users TestDoc.ods 
    chown: changing ownership of `TestDoc.ods': Permission denied
    This is how I mount the drive:
    Code:
    mount.cifs //192.168.1.220/FILES /mnt/temp/ -o user=*****,password=*****
    Why CIFS messes with my user:group attributes?
    Any suggestions how to addrss this issue?

    Besides gedit also has some issues when saving the files with Ctrl+S. The following messge appears:
    The operating system/shell determine what to do first from the permission bits on the file. Since the executable bit is set, it will try to execute the "program" first. However, since it isn't a script or executable it can't, hence the dialog you get. When you click on the "Display" button, it uses the file type metadata to determine which application (OOo) to run to display it. If there is none for the extension type, then it will treat it as a raw text file. However, since OOo is the registered application for this file type, it is what gets run to display the file.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  9. #9
    Linux Newbie blnl's Avatar
    Join Date
    Jan 2009
    Location
    The Netherlands
    Posts
    163

    Smile

    The problem is solved by mounting nfs drive with "nolock" option.

    My fstab now contains the following line:
    Code:
    192.168.1.220:/mnt/HD_a2/DATA /mnt/NASdata nfs hard,intr,nolock 0 0
    Fedora20.GNOME@Dell_Latitude_E6410
    Fedora14.GNOME@HP_Compaq_DC7100

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •