Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Mar 2008

    GPSIM untar errors out

    Trying to install software to check out my PIC (Microchip) asm but when I use:
    tar tvzf gpsim-0.24.0.tat.gz

    I get:
    -rwxr-xr-x 500/500 842579 2009-08-23 21:36 gpsim-0.24.0/configure
    -rw-r--r-- 500/500 274638 2009-08-23 21:36 gpsim-0.24.0/aclocal.m4

    gzip: stdin: unexpected end of file
    tar: Unexpected EOF in archive
    tar: Error is not recoverable: exiting now

    I know this is saying it found EOF but what is the gzip stuff. it the file possibly corrupted??
    This was downloaded from SourceForge. OR, is this truely where the file should end??

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Have you tried unziping the file first? I usually do this:
    gunzip -c gpsim-0.24.0.tar.gz | tar -xvf -
    That also leaves the original compressed tarball intact, but does the decompression outside of tar doing the extraction.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  3. #3
    Linux User
    Join Date
    Mar 2008

    GPSIM untar errors out

    Tried your suggestion, Rubberman, fortunately tar xvzf works just like gunzip & tar xvf but this made me reflect and trying gunzip -t also indicated that file might be corrupted. Downloaded another and it now is OK.
    Last edited by clickit; 12-20-2009 at 06:57 AM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts