Find the answer to your Linux question:
Results 1 to 5 of 5
First of all, I'm using Debian 3.0 with Woody k. Okay I've seen numerous questions about the same problem not only in this forum, but in other forums as well. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    DF
    DF is offline
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3

    Debian: Can't get X to work


    First of all, I'm using Debian 3.0 with Woody k.

    Okay I've seen numerous questions about the same problem not only in this forum, but in other forums as well. I have tried everything I've seen and I really can't get x to start; I get the classic problem "Fatal Server Error: No Screens Found"

    I'm using a ProSavageDDR chip with S3 graphics integrated card. In the list I was choosing savage, and 1024*768 60 Hz in the monitor (I'm using a SyncMaster 551v). I've tried it a couple of times and everytime I get the same error.

    I've tried withXF86config-4 but it denies me permission, even with root.

    I even tried selecting vesa, and the error this time was different. It said my screen was found and it even detected which brand and model, but to no surprise I got this error:

    Screen(s) found, but none have usable configuration

    Fatal server error:
    no screens found

    Any help will be greatly appreciated and I'll check this thread regularly. Cheers.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    what command are you using to start up X?

  3. #3
    DF
    DF is offline
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    startx and xinit

  4. $spacer_open
    $spacer_close
  5. #4
    DF
    DF is offline
    Just Joined!
    Join Date
    Oct 2004
    Posts
    3
    By the way, I'm getting exactly this:

    Code:
    (EE) VESA(0): No matching modes
    (II) Unloading /usr/X11R6/lib/modules/libvgahw.a
    (EE) Screen(s) found, but none have usable configuration

  6. #5
    Just Joined!
    Join Date
    Oct 2004
    Location
    Maine, USA
    Posts
    3
    I don't know if you have solved this yet, but I'm having the same problem on a new Debian Woody 3.0 installation.

    I've tired using "X -configure" and got the following message:

    XFree86 is not able to detect your mouse.
    Edit the file and correct the device.
    Your XF86Config file is /root/XF86Config.new
    To test the server run "XFree86 -xf86config /root/XF86Config.new

    I changed the mouse device to '/dev/psaux' which I knew was a problem and X sort of came up and hung. I had to use Ctrl-Alt-Back to get out of it.

    I changed the mouse protocol to 'Microsoft' and could move the mouse, but X still froze.

    When I have done this before I used xf86config to configure X and chose the lowest level components that would work. Then went in to /etc/X11/XF86Config with vi and changed parts of the configuration and kept trying until I got a decent system.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •