Find the answer to your Linux question:
Results 1 to 3 of 3
I can't get a program (wbar) to run directly from my user account, it fails saying "Image not found -> maybe using a relative path?". But if I run su ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2009
    Posts
    47

    program works as root, fails as user


    I can't get a program (wbar) to run directly from my user account, it fails saying "Image not found -> maybe using a relative path?". But if I run su -c "wbar", it shows up and manages to load the image.
    I think it has something to do with ImLib2 or whatever loads the image. I checked permissions on libImlib2.so.1 and it's world-readable and executable. Can libImlib2.a be causing this problem, set to 644? What else should I be checking?

  2. #2
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Is this what you are talking about:

    Linux.com :: Turn your launch bar into eye candy with wbar

    Did you download it from your distributions repositories? Did you get a README file with the download or any instructions? How did you install it?

  3. #3
    Just Joined!
    Join Date
    Jul 2009
    Posts
    47
    yes that's it. I installed it from a package, found on slackfind.net. I tried from source first and it gave me the same error. Just now I reinstalled it from the package and noticed this time a warning from ldconfig about /usr/local/lib/libImlib2.so.1 not being a symbolic link. I also tried running with exactly the arguments used in that article, and got a Segmentation Fault.

    I am pretty sure it's not the program, I manually installed a .pet, that didn't work, so I uninstalled that and tried a .deb. It's better, using the options in the article does not make a Segmentation Fault, but still the "Image not found -> ..." error comes up.

    edit: i re-built imlib2 and did not get the ldconfig error

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •