Find the answer to your Linux question:
Results 1 to 1 of 1
Hi. I was trying to get something going in wine. It changed my video mode from my default 1152x864 to 1024x768 in an options screen, but crashed when trying to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2008
    Posts
    1

    Lost a video mode


    Hi.

    I was trying to get something going in wine. It changed my video mode from my default 1152x864 to 1024x768 in an options screen, but crashed when trying to launch the main game to a black screen. I had to reset x with ctrl-alt-backspace but the screen stayed black. I rebooted and x comes up fine in 1024x768. If I try to put my mode back to the usual 1152 res, it goes black again. When I don't accept the new configuration within the 15 second timeout, it tries to revert to 1024, but the screen stays black. Ditto if I ctrl-alt-backspace again.

    The only way I've managed to get a screen back up is to reboot. I booted into windoze to see if I spontaneously lost the ability to do that resolution and it works fine (using the same refresh rate).

    For a long shot, I tried launching the original game that caused the problem, telling it to start at 1152 instead of 1024 (it broke it, maybe it could fix it?) but that didn't work either. So now I'm stuck with a system that can't do at least one res it should be able to do.

    I tried some other modes and refresh rates. Some work, and some produce weird results, not dissimilar to the effect you'd get on an old TV if you fiddled with H and V hold, but variable depending on where i move the mouse. Very strange.

    I tried resetting my xorg.conf with dpkg-reconfigure xorg-xserver but there isn't much in it to reset anyway, and the effect is unchanged from the original.

    That the behaviour is reproducible on this system suggests that X is remembering something about the 1152x864 mode that it can't actually do, and putting that info somewhere other than xorg.conf. Can anyone suggest how to fix the problem?

    KDE: 3.5.10
    X.Org X Server 1.4.2
    Release Date: 11 June 2008
    X Protocol Version 11, Revision 0
    Build Operating System: Linux Debian (xorg-server 2:1.4.2-10.lenny2)
    Current Operating System: Linux chris-linux 2.6.26-2-686 #1 SMP Wed Nov 4 20:45:37 UTC 2009 i686
    Build Date: 08 June 2009 09:12:57AM

    xorg.conf and Xorg.0.log are a gzipped text attachment as the forum is parsing the info therein as links.

    Onboard Intel graphics
    Compaq S710 Monitor
    No other graphics driver installed, so using whatever xorg natively installed when I put the OS on it.

    Thanks
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •