Find the answer to your Linux question:
Results 1 to 4 of 4
I assume that this would be the correct place to put this, because codelite is an application that you have to download via the Ubuntu Software center to get. But ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    7

    Ubuntu 9.10|codelite--Help getting Lua to compile properly


    I assume that this would be the correct place to put this, because codelite is an application that you have to download via the Ubuntu Software center to get. But anyhow...

    I have been playing around with codelite for a little while now, and I wanted to use it for the purpose of learning how to script and write programs in the Lua programming language. According to the program description it comes with the Lua support built in, but running it proves to me that it is solely a C++ application.

    This isn't an extreme problem, though, I've read that Lua is supposed to be programmed through C++ anyhow. I am having only one problem that needs the attention. I ran through the code and got an error telling me that it could not find the #include files for Lua. A quick check of the /usr/include/ files showed me that there were indeed none in there.

    That being said, I went to the Lua website and downloaded the source and binaries *.tar.gz file, extracted it to a folder called "Lua." I am unable to move the #include files from inside its include folder to the main one on /usr/include/.

    I have a feeling it is an administrator problem and that I need something involving the terminal or sudo to reach there. I have read around online, and they almost all say the same thing, telling me to navigate to the folder and "run make." I know what this is and how to do it, but it says that it cannot find the Makefile, which I have seen and know is in the folder, so it doesn't.

    Moving to the src folder within the Lua folder shows me that there is another Makefile, meaning that I have a second chance to make the files. I navigate to it, and then what do you know? Make works. Until the end, where I get a lot of errors and a termination of the process. Errors include Error 1 and Error 2, which I do not know what they are.

    So something must not be working properly. I can't find out what I'm supposed to "make," nor can I find any way to successfully get codelite to recognize the lua source files. Is there any easier way to do this? The INSTALL and README files are rather unhelpful and underdetailed to a person who is very new to Ubuntu and Lua.

    Thanks in advance.

  2. #2
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    just install lua5.1 and liblua5.1-0-dev packages
    Last edited by coopstah13; 01-25-2010 at 10:08 PM. Reason: wrong package name

  3. #3
    Just Joined!
    Join Date
    Dec 2009
    Posts
    7
    Where do I find those files? According to the Lua website there are only *.tar.gz's *.zip's, and *.exe's available for download.

    And if they are *.tar.gz's, then I am going to need a walkthrough on how to install them. X_X

  4. #4
    Linux Guru coopstah13's Avatar
    Join Date
    Nov 2007
    Location
    NH, USA
    Posts
    3,149
    use synaptic package manager...

    you should get used to installing everything from it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •