Find the answer to your Linux question:
Results 1 to 9 of 9
When I try to burn a file with non-english character like: Un condamné à mort s'est échappé ou Le vent souffle où il veut I get the following message: "The ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie imranka's Avatar
    Join Date
    Dec 2007
    Location
    Kolkata
    Posts
    181

    k3b The following file names have an invalid encoding.


    When I try to burn a file with non-english character like:
    Un condamné à mort s'est échappé ou Le vent souffle où il veut

    I get the following message:
    "The following filenames have an invalid encoding. You may fix this with the convmv tool:"

    How to solve this?

    BTW, If it needs, my locale are so:

    Code:
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=en_US.UTF-8
    Imran
    Linux User #467555 | Debian Squeeze | Intel(R) Core(TM)2 Duo CPU 4500 @ 2.20GHz | Gigabyte GA-G41MT-ES2L
    | 2 GB RAM | 320 GB SATA | Kernel: 2.6.32-5-686

  2. #2
    Linux Newbie imranka's Avatar
    Join Date
    Dec 2007
    Location
    Kolkata
    Posts
    181
    * bump *
    Imran
    Linux User #467555 | Debian Squeeze | Intel(R) Core(TM)2 Duo CPU 4500 @ 2.20GHz | Gigabyte GA-G41MT-ES2L
    | 2 GB RAM | 320 GB SATA | Kernel: 2.6.32-5-686

  3. #3
    Linux Enthusiast scathefire's Avatar
    Join Date
    Jan 2010
    Location
    Western Kentucky
    Posts
    626

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,655
    What do you mean by "burn a file"? Do you mean to add a file to a list to burn to a CD/DVD disc or ISO image? If so, the problem is likely with the limitations of the iso9660 file system you are likely trying to use.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  6. #5
    Linux Newbie imranka's Avatar
    Join Date
    Dec 2007
    Location
    Kolkata
    Posts
    181
    burn a file = add a file to a list

    And k3b doesn't let me add the file.

    Thanks
    Imran
    Linux User #467555 | Debian Squeeze | Intel(R) Core(TM)2 Duo CPU 4500 @ 2.20GHz | Gigabyte GA-G41MT-ES2L
    | 2 GB RAM | 320 GB SATA | Kernel: 2.6.32-5-686

  7. #6
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,655
    Quote Originally Posted by imranka View Post
    burn a file = add a file to a list

    And k3b doesn't let me add the file.

    Thanks
    ??? You can add any number of files to burn to a CD/DVD with k3b. You still are not being clear enough on what your problem is.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  8. #7
    Linux Newbie imranka's Avatar
    Join Date
    Dec 2007
    Location
    Kolkata
    Posts
    181


    I don't know how to be more clear than my original post.

    k3b doesn't let me add any file which contains non-english character. So, what i usually do is to modify the filename with only english character and then burn it. But if I want, to keep the file name as it is i.e. with 'ù', 'à' or 'é; then what I've to do?
    Imran
    Linux User #467555 | Debian Squeeze | Intel(R) Core(TM)2 Duo CPU 4500 @ 2.20GHz | Gigabyte GA-G41MT-ES2L
    | 2 GB RAM | 320 GB SATA | Kernel: 2.6.32-5-686

  9. #8
    Linux Newbie imranka's Avatar
    Join Date
    Dec 2007
    Location
    Kolkata
    Posts
    181


    I don't know how to be more clear than my original post.

    k3b doesn't let me add any file which contains non-english character. So, what i usually do is to modify the filename with only english character and then burn it. But if I want, to keep the file name as it is i.e. with 'ù', 'à' or 'é; then what I've to do?
    Imran
    Linux User #467555 | Debian Squeeze | Intel(R) Core(TM)2 Duo CPU 4500 @ 2.20GHz | Gigabyte GA-G41MT-ES2L
    | 2 GB RAM | 320 GB SATA | Kernel: 2.6.32-5-686

  10. #9
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,655
    Either k3b isn't set up to handle international languages, or the ISO9660 specification doesn't all the characters you are trying to use. Actually, mkisofs will allow Unicode character sets when you specify the -J (Joliet) or -joliet-long options, but then those discs will only work on Windows or Linux machines, though that restriction may not be a problem for you. In cany case, I don't think k3b directly supports those character sets - at least I haven't found any way to do so, even though it will allow you to burn a disc w/ Joliet extensions. So, you may have to use mkisofs or genisoimage directly.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •