Find the answer to your Linux question:
Results 1 to 2 of 2
hello, i am trying to use my logitech gamepad as a mouse using js2mouse. It is not working. i am running suse 11.2 I have downloaded and installed js2mouse with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    24

    js2mouse -cant get it to work


    hello,

    i am trying to use my logitech gamepad as a mouse using js2mouse. It is not working.

    i am running suse 11.2

    I have downloaded and installed js2mouse with no errors. when i run it i get:

    # js2mouse
    Number of axes : 6
    Number of buttons : 12
    Driver version : 131328
    Joystick name : Logitech Logitech Dual Action

    that looks good, it knows the name of my gamepad!!

    i have tried to configure it following the instructions at cedric.vincent.perso.free.fr/Projets/index.html -spefically this part:

    "3) Js2mouse as a second pointer with GPM :
    - It depends on your Linux distribution, so this is the most independant explanation that I can give... Adapt your own configuration files
    - Log as 'root' (if necessary)
    - Enter the following commands into a terminal :
    gpm -k
    gpm -m /dev/_YOUR_REAL_MOUSE_DEV_ -t _ITS_PROTOCOL_ -M -t ps2 -m /dev/j2m_fifo"

    based on that, I have tried both:

    gpm -m /dev/input/mouse1 -t ps2 -M -t js -m /dev/input/j2m_fifo

    and

    gpm -m /dev/input/mouse1 -t ps2 -M -t ps2 -m /dev/input/j2m_fifo

    i dont get any errors form the terminal, but it does not work.

    any help will be appreciated

    thanks

    strax

  2. #2
    Just Joined!
    Join Date
    Feb 2007
    Posts
    24
    still no luck with j2mouse. however i have found qjoypad. it works great!!

    thanks,

    x

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •