Find the answer to your Linux question:
Results 1 to 4 of 4
My efforts to install the new Firefox3.6: are going nowhere (literally, it seems)! After entereing: $ tar xvjf firefox-3.6.tar.bz2 on my linux box: [GCC 3.4.1 (Mandrakelinux 10.1 3.4.1-4mdk)] on linux2 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Lowell T.'s Avatar
    Join Date
    Aug 2004
    Location
    Harford County, MD
    Posts
    29

    Can't unzip firefox3.6 in my Mandrake OS


    My efforts to install the new Firefox3.6: are going nowhere (literally, it seems)! After entereing:

    $ tar xvjf firefox-3.6.tar.bz2

    on my linux box:

    [GCC 3.4.1 (Mandrakelinux 10.1 3.4.1-4mdk)] on linux2

    the end result comes to nothing. What I should (why would it be different from any other install?) end up with is a new directory "firefox3.6" or something very similar. I don't. I get nothing. Nadda. Once I hit the "tar xvjf..." button, I get the usual 'print (to screen)' flurry of activity. A sample:

    firefox/modules/SpatialNavigation.js
    firefox/modules/FileUtils.jsm
    firefox/README.txt
    firefox/libplc4.so
    firefox/application.ini
    firefox/searchplugins/
    firefox/searchplugins/answers.xml
    firefox/searchplugins/google.xml

    But, I'll be darned if I can find all of this afterward. There certainly was not (as I've noted) a new directory created:

    -rw-rw-r-- 1 lo lo 10161471 Feb 18 23:15 firefox-3.6.tar.bz2
    drwxr-x--- 17 lo lo 4096 Feb 12 19:49 Python-3.1.1/
    -rw-rw-r-- 1 lo lo 11525876 Feb 11 13:54 Python-3.1.1.tgz
    drwxr-xr-x 13 lo lo 4096 Jan 15 17:41 firefox/

    The "firefox/" directory that is part of the above listing? Notice the <Jan 15> date. Obviously an effort from another time. The listing [above] was generated with "ls -t", so the most recent activity is at the top. I simply can't find all the unpacked stuff that was generated with tar. I've looked in /home/.mozilla, tried "locate", all to no avail. "Google" can't seem to understand the problem I'm encountering. Who'd care to tackle this on this beautiful (snow free!!) Sunday morning?

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Have you tried to double click on firefox script available in extracted Firefox folder?

    Firefox works that way only. Just double click on script or open Terminal and navigate to firefox folder. Execute firefox command. If throws error, post error message here.

    Other way is, download and install Firefox using package manager. It will create Firefox Icon in Menu.
    If you install it through tar.bz2, you have to create Icon for it yourself. Just create link of firefox script in Menu.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux Guru reed9's Avatar
    Join Date
    Feb 2009
    Location
    Boston, MA
    Posts
    4,651
    Are you actually using Mandrake Linux? Given the mention of GCC 3.4.1, which came out in 2004, and Mandrake Linux, the last release of which was also around 2004, I'm guessing yes. In which case, I doubt Firefox 3.6 will run on such an old distro.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! Lowell T.'s Avatar
    Join Date
    Aug 2004
    Location
    Harford County, MD
    Posts
    29
    Quote Originally Posted by devils casper View Post
    Have you tried to double click on firefox script available in extracted Firefox folder?.
    That's the whole point...there is no extracted Firefox folder.

    I just downloaded another copy of Firefox3.6, and installed it:

    tar xvjf firefox-3.6.tar.bz2 | tee catch.log

    but this time capturing all the output in a text file. Any display of the content of that catch file would only mirror what I've already offered a sample of above. I'm able to display [some -- don't know if it's the correct one} copy of README.txt that is only a 4-liner imploring me to go to a firefox web site for help -- dong so doesn't live up to its' promise.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •