Find the answer to your Linux question:
Results 1 to 5 of 5
Hello, linux newbie here... well before I get to my specific problem, I'm running Xubuntu 9.10 (karmic) on a Playstation 3 (PPC). I am attempting to install "Qemu-launcher". 1. Tried ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2010
    Posts
    3

    Exclamation Qemu Hell...help is appreciated


    Hello, linux newbie here...

    well before I get to my specific problem, I'm running Xubuntu 9.10 (karmic) on a Playstation 3 (PPC). I am attempting to install "Qemu-launcher".

    1. Tried to install "qemu-launcher" via "Add / Remove Applications". it gave me an error about conflicting packages, and deferred me to Synaptic Package Manager.

    2. Tried to install "qemu-launcher" in Synaptic Package Manager.
    error: "Could not mark all packages for installation or upgrade -- the following packages have unresolvable dependencies. Make sure that all required repositories are added and enabled in the preferences. -- qemu-launcher: Depends: qemu-kvm (>=0.11.0~rc1) but it is not installable"

    3. Tried to download "qemu-launcher" via "apt-get" in terminal - same error as in Synaptic

    4. Attempted to download "qemu-kvm" via "apt-get" in terminal:
    "package qemu-kvm is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source. E: package qemu-kvm has no installation candidate."

    5. Found and downloaded "qemu-kvm-0.11.0~rc1.orig.tar.gz". Extracted archive.

    6. Compiled and installed via terminal:
    ./configure
    make
    sudo make install

    7. Next tried to download "Qemu-launcher" in;
    "Add / Remove Applications" : referred to Synaptic
    Synaptic Package Manager - same error as before (doesn't recognize that i've installed it)

    8. Found and Downloaded "qemu-launcher_1.7.4.tar.gz" Extracted archive.

    9. installed via terminal:
    sudo make install

    10. Now "qemu-launcher" installed, but will not run.

    Also, Synaptic does not recognize that I have it installed. And finally, there is no "qemu" in root/usr/bin. what should I do? i'm all out of ideas. thanks so much.

  2. #2
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,763
    I am not sure if this is just an exercise, but I don't think Qemu is going to be able to do much for you on the ~240MB RAM that the PS3 gives you...

    Are you trying to get a useful Qemu install out of this?

    Synaptic Package Manager - same error as before (doesn't recognize that i've installed it)
    If you install something from source code (which is what you indicated), then the package manager is being bypassed and won't know about it. You will find more information in the forum FAQ "Installing Software in Linux" or from Google.

    Your Synaptic error says that you don't have all of the necessary online repositories listed/enabled in order for the required packages to be installed.
    Last edited by HROAdmin26; 03-08-2010 at 07:22 AM.

  3. #3
    Just Joined!
    Join Date
    Mar 2010
    Posts
    3
    well i'm running xubuntu as my computer now since my laptop died (windows...figures) -- but i need to run some small logic applications (.exes) for a class (i'm attending college). so i was just going to create a windows xp live CD (bart PE) just to run those programs when i need to. i would use wine, but it won't work for PPC. so i must emulate x86 using Qemu then boot the win xp PE. but everything i try to do fails miserably. i seem to be the only person with this problem, ive been searching for days now.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,763
    Quote Originally Posted by blueskies43 View Post
    well i'm running xubuntu as my computer now since my laptop died (windows...figures) -- but i need to run some small logic applications (.exes) for a class (i'm attending college). so i was just going to create a windows xp live CD (bart PE) just to run those programs when i need to. i would use wine, but it won't work for PPC. so i must emulate x86 using Qemu then boot the win xp PE. but everything i try to do fails miserably. i seem to be the only person with this problem, ive been searching for days now.
    Edit: I removed my comment about the CPU restrictions based on Wikipedia's notes about Qemu.

    Google led me to this Ubuntu PowerPCFAQ.

    ...which then lead to this FAQ about installing Qemu.

    ...which then says that Qemu should be available in the Universe repo:

    QEMU is available as a standard package in the Universe repository.
    There is an Ubuntu wiki page about how to manage repositories.
    Last edited by HROAdmin26; 03-08-2010 at 07:38 AM.

  6. #5
    Just Joined!
    Join Date
    Mar 2010
    Posts
    3
    Well I already had enabled the universe repositories through the terminal:
    sudo gedit /etc/apt/sources.list
    then i unflagged the universe repositories (although that tutorial showed a way tro do that through the menus that looks way easier...lol)
    and then I reloaded and everything, but it still says:

    "the following packages have unresolvable dependencies. Make sure that all required repositories are added and enabled in the preferences. -- qemu-launcher: Depends: qemu-kvm (>=0.11.0~rc1) but it is not installable"

    Also, that file will not show up in the list of options in Synaptic Package Manager....so I don't really know what to do. Is there any way to find out where that package is and give synaptic an updated link? or something like that?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •