PureFTP D with authd problem

--------------------------------------------------------------------------------

HI All,

I installed pure-ftpd-1.0.28 with authd on my achine but's NOT working fine.
Following are steps are followed:
1. I downloaded pure-ftpd-1.0.28 form pur ftp site.
2.gunzip pure-ftpd-1.0.28.tar.gz
3.tar -xvf pure-ftpd-1.0.28.tar
4.Go to directory using cd pure-ftpd-1.0.28
5../configure --prefix=/path/pure-ftpd-1.0.28 --with-extauth
6. make check
7.make install
Also tried with ./configure --prefix=/path/pure-ftpd-1.0.28 --with-everything.

Now i start pure ftpd with my external program
./pure-authd -s /var/run/ftpd.sock -r /path/runauth.sh &

After that ./pure-ftpd -l extauth:/var/run/ftpd.sock &

My runauth.sh just echoes
auth_ok:1
uid:42
gid:21
dir:/home/j
end

If i tried to connect to ftp as follows:

# ftp localhost
Connected to localhost (127.0.0.1).
220---------- Welcome to Pure-FTPd [privsep] ----------
220-You are user number 1 of 50 allowed.
220-Local time is now 11:22. Server port: 21.
220 You will be disconnected after 15 minutes of inactivity.
Name (localhost:u9031562): ram
331 User ram OK. Password required
Password:
530 Login authentication failed
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> quit

It's just script file which authenticates the user but till it's not authenticating.
Please let me know your suggestion. Is there any problem in installtaion or it's authd process issue?