Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I try to run Mesa gears example and I get following error: Code: freeglut (./gears): Unable to create direct context rendering for window 'Gears' This may hurt performance. though ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2009
    Posts
    20

    "Unable to create context rendering" error when run OpenGL application


    Hello,
    I try to run Mesa gears example and I get following error:
    Code:
    freeglut (./gears): Unable to create direct context rendering for window 'Gears'
    This may hurt performance.
    though the application runs successfully, but I guess that in future I will have much problems with productivity.

    I run Linux CentOS 5 on WMvare 7. Mesa's version is 6.5
    Relevant output of lspci -v gives:
    Code:
    00:0f.0 VGA compatible controller: VMware SVGA II Adapter (prog-if 00 [VGA controller])
            Subsystem: VMware SVGA II Adapter
            Flags: bus master, medium devsel, latency 64, IRQ 9
            I/O ports at 10d0 [size=16]
            Memory at d0000000 (32-bit, non-prefetchable) [size=128M]
            Memory at d8000000 (32-bit, non-prefetchable) [size=8M]
            [virtual] Expansion ROM at 30000000 [disabled] [size=32K]
            Capabilities: [40] Vendor Specific Information
    Any one have idea? There is driver of vmvare for CentOS?
    Thank you for ahead.

  2. #2
    Just Joined!
    Join Date
    Dec 2009
    Posts
    20
    So, like I understood, while I run Linux on VMware, this error isn't significant. The solution is to install Linux on host, and then it will own direct access to graphic card.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •