Find the answer to your Linux question:
Results 1 to 2 of 2
I have set up a FAT32 partition to be shared between my Windows 2000 and Fedora Core 2 installations. It is entered in /etc/fstab as /mnt/share, owned by root and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    1

    Unable to preserve timestamps as ordinary user


    I have set up a FAT32 partition to be shared between my Windows 2000 and Fedora Core 2 installations. It is entered in /etc/fstab as /mnt/share, owned by root and a group called "share", of which my user account is a member. The "share" group has full access to /mnt/share.

    I first noticed this issue when copying photo image files from my home directory to the share, using konqueror. The timestamps were being lost in transit. I tried using cp, but I got an "operation not permitted" message - (referring to the timestamp operation) - for each file I tried to copy.

    I have since managed to perform the timestamp preservation operation as root, but then got a weird response to an ls in the target directory: the filenames showed red and flashing, and instead of file properties I saw just question marks. Remounting the share resulted in a correct response from ls, with timestamps intact.

    This is all far from ideal, and I can work none of it out. Please help.

  2. #2
    Linux User Stefann's Avatar
    Join Date
    Nov 2004
    Location
    Boise, ID
    Posts
    340
    Hhhhhmmmmm, very interesting, sorry but I have no clue, but your question solved one of my problems, sorry i can't help, let me se if GOOOOGLE has any good answers for you.
    Nothing is worse than ten penguins fighting over which is better, vi or emacs.
    Registered Linux User #404402
    Finally I'm back on LF after a long while.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •